# CVE-2024-22188: TYPO3 Install Tool vulnerable to Code Execution

> Authenticated administrators can execute arbitrary shell commands via the Install Tool, leading to code execution on the server.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2024
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-5w2h-59j3-8x5w

## What is CVE-2024-22188?

CVE-2024-22188 is a high-severity command injection vulnerability in Typo3 Typo3, published on 5 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

TYPO3 before 13.0.1 allows an authenticated admin user (with system maintainer privileges) to execute arbitrary shell commands (with the privileges of the web server) via a command injection vulnerability in form fields of the Install Tool. The fixed versions are 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, and 13.0.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-22188?

12 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.43 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.43 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.35 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.35 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.11 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.11 |
| `typo3/cms-core` | Packagist | From 13.0.0 | 13.0.1 |
| `typo3/cms-core` | Packagist | From 13.0.0 | 13.0.1 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.57 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.57 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.46 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.46 |

Products: Typo3 Typo3.

## How do I fix CVE-2024-22188?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.43, 11.5.35, 12.4.11 or 13.0.1.

## Is CVE-2024-22188 being exploited?

There is no known exploitation of CVE-2024-22188 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22188 and fix it if it is affected.

What it is: CVE-2024-22188 is a high-severity command injection vulnerability in Typo3 Typo3, published on 5 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22188 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.43
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.43
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.35
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.35
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.11
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.11
- typo3/cms-core (Packagist): affected from 13.0.0; fixed in 13.0.1
- typo3/cms-core (Packagist): affected from 13.0.0; fixed in 13.0.1
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.57
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.57
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.46
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.46

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22188/ (Markdown: https://insights.sbomify.com/CVE-2024-22188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22188
- OSV: https://osv.dev/vulnerability/CVE-2024-22188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22188/
Summaries are generated and may contain mistakes; the official description above is the record.
