# CVE-2024-22190: Untrusted search path under some conditions on Windows allows arbitrary code execution

> An attacker can execute arbitrary code on Windows by placing malicious executables in an untrusted repository directory when specific shell features are enabled.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jan 2024
- **Updated:** 3 Sep 2024
- **Also known as:** GHSA-2mqj-m65w-jghx, PYSEC-2024-4, ROOT-APP-PYPI-CVE-2024-22190

## What is CVE-2024-22190?

CVE-2024-22190 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 11 Jan 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

GitPython is a python library used to interact with Git repositories. There is an incomplete fix for CVE-2023-40590. On Windows, GitPython uses an untrusted search path if it uses a shell to run `git`, as well as when it runs `bash.exe` to interpret hooks. If either of those features are used on Windows, a malicious `git.exe` or `bash.exe` may be run from an untrusted repository. This issue has been patched in version 3.1.41.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2024-22190?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.41 |
| `gitpython` | PyPI | All versions | 3.1.41 |
| `GitPython` | PyPI | All versions | 3.1.41 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2024-22190?

Upgrade gitpython to 3.1.41 or later.

## Is CVE-2024-22190 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22190 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22190 and fix it if it is affected.

What it is: CVE-2024-22190 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 11 Jan 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22190 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.41
- gitpython (PyPI): affected all versions; fixed in 3.1.41
- GitPython (PyPI): affected all versions; fixed in 3.1.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22190/ (Markdown: https://insights.sbomify.com/CVE-2024-22190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22190
- OSV: https://osv.dev/vulnerability/CVE-2024-22190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22190/
Summaries are generated and may contain mistakes; the official description above is the record.
