# CVE-2024-22193: vantage6 unencrypted task can be created in encrypted collaboration

> Users can accidentally store sensitive task inputs unencrypted in encrypted collaborations, leading to potential data exposure.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-rjmv-52mp-gjrr, PYSEC-2024-32

## What is CVE-2024-22193?

CVE-2024-22193 is a low-severity vulnerability in vantage6, published on 30 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The vantage6 technology enables to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC). There are no checks on whether the input is encrypted if a task is created in an encrypted collaboration. Therefore, a user may accidentally create a task with sensitive input data that will then be stored unencrypted in a database.  Users should ensure they set the encryption setting correctly.  This vulnerability is patched in 4.2.0.

Weakness: CWE-922 (Insecure Storage of Sensitive Information)

## Which versions are affected by CVE-2024-22193?

3 open source packages ship an affected version, including vantage6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.2.0 |
| `vantage6` | PyPI | All versions | 4.2.0 |
| `vantage6` | PyPI | All versions | 4.2.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2024-22193?

Upgrade vantage6 to 4.2.0 or later.

## Is CVE-2024-22193 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22193 exists.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22193 and fix it if it is affected.

What it is: CVE-2024-22193 is a low-severity vulnerability in vantage6, published on 30 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22193 exists.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.2.0
- vantage6 (PyPI): affected all versions; fixed in 4.2.0
- vantage6 (PyPI): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22193/ (Markdown: https://insights.sbomify.com/CVE-2024-22193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22193
- OSV: https://osv.dev/vulnerability/CVE-2024-22193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22193/
Summaries are generated and may contain mistakes; the official description above is the record.
