CVE-2024-22202 User Removal Page Allows Spoofing Of User Details

Medium 5.7 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-22202?

CVE-2024-22202 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024.

Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. phpMyFAQ's user removal page allows an attacker to spoof another user's detail, and in turn make a compelling phishing case for removing another user's account. The front-end of this page doesn't allow changing the form details, an attacker can utilize a proxy to intercept this request and submit other data. Upon submitting this form, an email is sent to the administrator informing them that this user wants to delete their account. An administrator has no way of telling the difference between the actual user wishing to delete their account or the attacker issuing this for an account they do not control. This issue has been patched in version 3.2.5.

Weakness: CWE-284

Which versions are affected by CVE-2024-22202?

2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.

PackageAffectedFixed in
phpmyfaq/phpmyfaq PackagistAll versions3.2.5
phpmyfaq/phpmyfaq PackagistAll versions3.2.5

Products include Phpmyfaq Phpmyfaq.

How do I fix CVE-2024-22202?

Upgrade phpmyfaq/phpmyfaq to 3.2.5 or later.

Is CVE-2024-22202 being exploited?

There is no known exploitation of CVE-2024-22202 in the wild and no public exploit code.

All Phpmyfaq Phpmyfaq vulnerabilities

Sources

Also known as GHSA-6648-6g96-mg35.

Is CVE-2024-22202 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free