{"answers":{"affected":"2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-22202 in the wild and no public exploit code.","fix":"Upgrade phpmyfaq/phpmyfaq to 3.2.5 or later.","what":"CVE-2024-22202 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024."},"fix_prompt":"Check this codebase for CVE-2024-22202 and fix it if it is affected.\n\nWhat it is: CVE-2024-22202 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024. \nExploitation: There is no known exploitation of CVE-2024-22202 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 3.2.5\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 3.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22202/ (Markdown: https://insights.sbomify.com/CVE-2024-22202/index.md)","id":"CVE-2024-22202","markdown":"https://insights.sbomify.com/CVE-2024-22202/index.md","name":"CVE-2024-22202","record":{"aliases":["GHSA-6648-6g96-mg35"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. phpMyFAQ's user removal page allows an attacker to spoof another user's detail, and in turn make a compelling phishing case for removing another user's account. The front-end of this page doesn't allow changing the form details, an attacker can utilize a proxy to intercept this request and submit other data. Upon submitting this form, an email is sent to the administrator informing them that this user wants to delete their account. An administrator has no way of telling the difference between the actual user wishing to delete their account or the attacker issuing this for an account they do not control. This issue has been patched in version 3.2.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"User Removal Page Allows Spoofing Of User Details","id":"CVE-2024-22202","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":null,"year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22203"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.5"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-6648-6g96-mg35"},{"ecosystem":"Packagist","fixed":["3.2.5"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-6648-6g96-mg35"}],"prev":{"headline":"Jetty connection leaking on idle timeout when TCP congested","id":"CVE-2024-22201"},"products":["phpMyFAQ"],"published":"2024-02-05","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["thorsten"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-22202/"}