# CVE-2024-22202: User Removal Page Allows Spoofing Of User Details


- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-6648-6g96-mg35

## What is CVE-2024-22202?

CVE-2024-22202 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024. 

### Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. phpMyFAQ's user removal page allows an attacker to spoof another user's detail, and in turn make a compelling phishing case for removing another user's account. The front-end of this page doesn't allow changing the form details, an attacker can utilize a proxy to intercept this request and submit other data. Upon submitting this form, an email is sent to the administrator informing them that this user wants to delete their account. An administrator has no way of telling the difference between the actual user wishing to delete their account or the attacker issuing this for an account they do not control. This issue has been patched in version 3.2.5.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-22202?

2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 3.2.5 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 3.2.5 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2024-22202?

Upgrade phpmyfaq/phpmyfaq to 3.2.5 or later.

## Is CVE-2024-22202 being exploited?

There is no known exploitation of CVE-2024-22202 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22202 and fix it if it is affected.

What it is: CVE-2024-22202 is a medium-severity vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2024-22202 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 3.2.5
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22202/ (Markdown: https://insights.sbomify.com/CVE-2024-22202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22202
- OSV: https://osv.dev/vulnerability/CVE-2024-22202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22202/
Summaries are generated and may contain mistakes; the official description above is the record.
