{"answers":{"affected":"3 open source packages ship an affected version, including whoogle-search. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22204 exists.","fix":"Upgrade whoogle-search to 0.8.4 or later.","what":"CVE-2024-22204 is a medium-severity path traversal vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-22204 and fix it if it is affected.\n\nWhat it is: CVE-2024-22204 is a medium-severity path traversal vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22204 exists.\n\nAffected packages and fixed versions:\n- whoogle-search (PyPI): affected all versions; fixed in 0.8.4\n- whoogle-search (PyPI): affected all versions; fixed in 0.8.4\n- whoogle-search (PyPI): affected all versions; fixed in 0.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22204/ (Markdown: https://insights.sbomify.com/CVE-2024-22204/index.md)","id":"CVE-2024-22204","markdown":"https://insights.sbomify.com/CVE-2024-22204/index.md","name":"CVE-2024-22204","record":{"aliases":["GHSA-hh2q-qv66-jcqg","PYSEC-2024-23"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Whoogle Search","requires_auth":"none","summary":"Attackers can overwrite files on the server via path traversal in the configuration feature, requiring specific settings to be enabled.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"whoogle_search","vendor":"benbusby"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Whoogle Search is a self-hosted metasearch engine. Versions 0.8.3 and prior have a limited file write vulnerability when the configuration options in Whoogle are enabled. The `config` function in `app/routes.py` does not validate the user-controlled `name` variable on line 447 and `config_data` variable on line 437. The `name` variable is insecurely concatenated in `os.path.join`, leading to path manipulation. The POST data from the `config_data` variable is saved with `pickle.dump` which leads to a limited file write. However, the data that is saved is earlier transformed into a dictionary and the `url` key value pair is added before the file is saved on the system. All in all, the issue allows us to save and overwrite files on the system that the application has permissions to, with a dictionary containing arbitrary data and the `url` key value, which is a limited file write. Version 0.8.4 contains a patch for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Whoogle Search Limited File Write vulnerability","id":"CVE-2024-22204","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":6,"next":{"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22205"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":null,"source":"GHSA-hh2q-qv66-jcqg"},{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"GHSA-hh2q-qv66-jcqg"},{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"PYSEC-2024-23"}],"prev":{"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22203"},"products":["whoogle-search"],"published":"2024-01-23","related":[{"cvss_score":9.1,"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22203","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":9.1,"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22205","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":7.3,"headline":"Whoogle allows attackers to execute arbitrary code via supplying a crafted search query","id":"CVE-2024-53305","kev_date_added":null,"published":"2025-04-16"},{"cvss_score":6.1,"headline":"Whoogle Search Cross-site Scripting vulnerability","id":"CVE-2024-22417","kev_date_added":null,"published":"2024-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["benbusby"]},"summary":"Attackers can overwrite files on the server via path traversal in the configuration feature, requiring specific settings to be enabled.","url":"https://insights.sbomify.com/CVE-2024-22204/"}