# CVE-2024-22204: Whoogle Search Limited File Write vulnerability

> Attackers can overwrite files on the server via path traversal in the configuration feature, requiring specific settings to be enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-hh2q-qv66-jcqg, PYSEC-2024-23

## What is CVE-2024-22204?

CVE-2024-22204 is a medium-severity path traversal vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Whoogle Search is a self-hosted metasearch engine. Versions 0.8.3 and prior have a limited file write vulnerability when the configuration options in Whoogle are enabled. The `config` function in `app/routes.py` does not validate the user-controlled `name` variable on line 447 and `config_data` variable on line 437. The `name` variable is insecurely concatenated in `os.path.join`, leading to path manipulation. The POST data from the `config_data` variable is saved with `pickle.dump` which leads to a limited file write. However, the data that is saved is earlier transformed into a dictionary and the `url` key value pair is added before the file is saved on the system. All in all, the issue allows us to save and overwrite files on the system that the application has permissions to, with a dictionary containing arbitrary data and the `url` key value, which is a limited file write. Version 0.8.4 contains a patch for this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-22204?

3 open source packages ship an affected version, including whoogle-search. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `whoogle-search` | PyPI | All versions | 0.8.4 |
| `whoogle-search` | PyPI | All versions | 0.8.4 |
| `whoogle-search` | PyPI | All versions | 0.8.4 |

Products: Benbusby Whoogle Search.

## How do I fix CVE-2024-22204?

Upgrade whoogle-search to 0.8.4 or later.

## Is CVE-2024-22204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22204 exists.

## Other vulnerabilities in benbusby whoogle-search

- [CVE-2024-22203](https://insights.sbomify.com/CVE-2024-22203/): Whoogle Search Server Side Request Forgery vulnerability (critical 9.1)
- [CVE-2024-22205](https://insights.sbomify.com/CVE-2024-22205/): Whoogle Search Server Side Request Forgery vulnerability (critical 9.1)
- [CVE-2024-53305](https://insights.sbomify.com/CVE-2024-53305/): Whoogle allows attackers to execute arbitrary code via supplying a crafted search query (high 7.3)
- [CVE-2024-22417](https://insights.sbomify.com/CVE-2024-22417/): Whoogle Search Cross-site Scripting vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22204 and fix it if it is affected.

What it is: CVE-2024-22204 is a medium-severity path traversal vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22204 exists.

Affected packages and fixed versions:
- whoogle-search (PyPI): affected all versions; fixed in 0.8.4
- whoogle-search (PyPI): affected all versions; fixed in 0.8.4
- whoogle-search (PyPI): affected all versions; fixed in 0.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22204/ (Markdown: https://insights.sbomify.com/CVE-2024-22204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22204
- OSV: https://osv.dev/vulnerability/CVE-2024-22204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22204/
Summaries are generated and may contain mistakes; the official description above is the record.
