# CVE-2024-22206: @clerk/nextjs auth() and getAuth() methods vulnerable to insecure direct object reference (IDOR)

> Attackers can bypass authentication checks in Clerk's Next.js library to access unauthorized data or escalate privileges.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2024
- **Updated:** 14 Nov 2024
- **Also known as:** GHSA-q6w5-jg5q-47vg

## What is CVE-2024-22206?

CVE-2024-22206 is a critical missing authorization vulnerability in clerk javascript, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Clerk helps developers build user management. Unauthorized access or privilege escalation due to a logic flaw in auth() in the App Router or getAuth() in the Pages Router. This vulnerability was patched in version 4.29.3.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-287 (Improper Authentication), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-22206?

2 open source packages ship an affected version, including @clerk/nextjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@clerk/nextjs` | npm | From 4.7.0 | 4.29.3 |
| `@clerk/nextjs` | npm | From 4.7.0 | 4.29.3 |

Products: Clerk Javascript.

## How do I fix CVE-2024-22206?

Upgrade @clerk/nextjs to 4.29.3 or later.

## Is CVE-2024-22206 being exploited?

There is no known exploitation of CVE-2024-22206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22206 and fix it if it is affected.

What it is: CVE-2024-22206 is a critical missing authorization vulnerability in clerk javascript, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22206 in the wild and no public exploit code.

Affected packages and fixed versions:
- @clerk/nextjs (npm): affected from 4.7.0; fixed in 4.29.3
- @clerk/nextjs (npm): affected from 4.7.0; fixed in 4.29.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22206/ (Markdown: https://insights.sbomify.com/CVE-2024-22206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22206
- OSV: https://osv.dev/vulnerability/CVE-2024-22206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22206/
Summaries are generated and may contain mistakes; the official description above is the record.
