CVE-2024-22233 CVE-2024-22233: Spring Framework server Web DoS Vulnerability

High 7.5 Published Updated

Attackers can cause denial of service in Spring MVC applications using specific Spring Security versions via crafted HTTP requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-22233?

CVE-2024-22233 is a high-severity denial of service vulnerability in Vmware Spring Framework, published on 22 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition.

Specifically, an application is vulnerable when all of the following are true:

* the application uses Spring MVC * Spring Security 6.1.6+ or 6.2.1+ is on the classpath

Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.

Weakness: CWE-400

Which versions are affected by CVE-2024-22233?

4 open source packages ship an affected version, including org.springframework:spring-core. It affects 1 product.

PackageAffectedFixed in
org.springframework:spring-core MavenFrom 6.0.156.0.16
org.springframework:spring-core MavenFrom 6.0.156.0.16
org.springframework:spring-core MavenFrom 6.1.26.1.3
org.springframework:spring-core MavenFrom 6.1.26.1.3

Products include Vmware Spring Framework.

How do I fix CVE-2024-22233?

Upgrade org.springframework:spring-core to a fixed version for your release line: 6.0.16 or 6.1.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-22233 being exploited?

There is no known exploitation of CVE-2024-22233 in the wild and no public exploit code.

All Vmware Spring Framework vulnerabilities

Sources

Also known as GHSA-r4q3-7g4q-x89m.

Is CVE-2024-22233 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free