# CVE-2024-22233: CVE-2024-22233: Spring Framework server Web DoS Vulnerability

> Attackers can cause denial of service in Spring MVC applications using specific Spring Security versions via crafted HTTP requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-r4q3-7g4q-x89m

## What is CVE-2024-22233?

CVE-2024-22233 is a high-severity denial of service vulnerability in Vmware Spring Framework, published on 22 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition.

Specifically, an application is vulnerable when all of the following are true:

  *  the application uses Spring MVC
  *  Spring Security 6.1.6+ or 6.2.1+ is on the classpath

Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-22233?

4 open source packages ship an affected version, including org.springframework:spring-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | From 6.0.15 | 6.0.16 |
| `org.springframework:spring-core` | Maven | From 6.0.15 | 6.0.16 |
| `org.springframework:spring-core` | Maven | From 6.1.2 | 6.1.3 |
| `org.springframework:spring-core` | Maven | From 6.1.2 | 6.1.3 |

Products: Vmware Spring Framework.

## How do I fix CVE-2024-22233?

Upgrade org.springframework:spring-core to a fixed version for your release line: 6.0.16 or 6.1.3.

## Is CVE-2024-22233 being exploited?

There is no known exploitation of CVE-2024-22233 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22233 and fix it if it is affected.

What it is: CVE-2024-22233 is a high-severity denial of service vulnerability in Vmware Spring Framework, published on 22 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22233 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected from 6.0.15; fixed in 6.0.16
- org.springframework:spring-core (Maven): affected from 6.0.15; fixed in 6.0.16
- org.springframework:spring-core (Maven): affected from 6.1.2; fixed in 6.1.3
- org.springframework:spring-core (Maven): affected from 6.1.2; fixed in 6.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22233/ (Markdown: https://insights.sbomify.com/CVE-2024-22233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22233
- OSV: https://osv.dev/vulnerability/CVE-2024-22233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22233/
Summaries are generated and may contain mistakes; the official description above is the record.
