CVE-2024-22234 CVE-2024-22234: Broken Access Control in Spring Security With Direct Use of isFullyAuthenticated
Developers using Spring Security must upgrade to prevent authentication bypass when null is passed to isFullyAuthenticated.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-22234?
CVE-2024-22234 is a high-severity authentication bypass vulnerability in Spring Security, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Spring Security, versions 6.1.x prior to 6.1.7 and versions 6.2.x prior to 6.2.2, an application is vulnerable to broken access control when it directly uses the AuthenticationTrustResolver.isFullyAuthenticated(Authentication) method.
Specifically, an application is vulnerable if:
* The application uses AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly and a null authentication parameter is passed to it resulting in an erroneous true return value.
An application is not vulnerable if any of the following is true:
* The application does not use AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly. * The application does not pass null to AuthenticationTrustResolver.isFullyAuthenticated * The application only uses isFullyAuthenticated via Method Security https://docs.spring.io/spring-security/reference/servlet/authorization/method-security.html or HTTP Request Security https://docs.spring.io/spring-security/reference/servlet/authorization/authorize-http-requests.html
Weakness: CWE-284
Which versions are affected by CVE-2024-22234?
4 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-core Maven | From 6.1.0 | 6.1.7 |
org.springframework.security:spring-security-core Maven | From 6.1.0 | 6.1.7 |
org.springframework.security:spring-security-core Maven | From 6.2.0 | 6.2.2 |
org.springframework.security:spring-security-core Maven | From 6.2.0 | 6.2.2 |
Products include Vmware Spring Security.
How do I fix CVE-2024-22234?
Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 6.1.7 or 6.2.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2024-22234 being exploited?
There is no known exploitation of CVE-2024-22234 in the wild and no public exploit code.
Other vulnerabilities in Spring Security
- CVE-2014-3527 Authorization Bypass in Spring Security
- CVE-2026-59354 Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata
- CVE-2026-59270 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces
- CVE-2026-22732 Under Some Conditions Spring Security HTTP Headers Are not Written
- CVE-2023-34034 Access Control Bypass in Spring Security
Sources
Also known as ECHO-4afd-6578-ce80, GHSA-w3w6-26f2-p474, ROOT-APP-MAVEN-CVE-2024-22234.