# CVE-2024-22234: CVE-2024-22234: Broken Access Control in Spring Security With Direct Use of isFullyAuthenticated

> Developers using Spring Security must upgrade to prevent authentication bypass when null is passed to isFullyAuthenticated.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** ECHO-4afd-6578-ce80, GHSA-w3w6-26f2-p474, ROOT-APP-MAVEN-CVE-2024-22234

## What is CVE-2024-22234?

CVE-2024-22234 is a high-severity authentication bypass vulnerability in Spring Security, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Spring Security, versions 6.1.x prior to 6.1.7 and versions 6.2.x prior to 6.2.2, an application is vulnerable to broken access control when it directly uses the AuthenticationTrustResolver.isFullyAuthenticated(Authentication) method.

Specifically, an application is vulnerable if:

  *  The application uses AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly and a null authentication parameter is passed to it resulting in an erroneous true return value.

An application is not vulnerable if any of the following is true:

  *  The application does not use AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly.
  *  The application does not pass null to AuthenticationTrustResolver.isFullyAuthenticated
  *  The application only uses isFullyAuthenticated via  Method Security https://docs.spring.io/spring-security/reference/servlet/authorization/method-security.html  or  HTTP Request Security https://docs.spring.io/spring-security/reference/servlet/authorization/authorize-http-requests.html

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-22234?

4 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 6.1.0 | 6.1.7 |
| `org.springframework.security:spring-security-core` | Maven | From 6.1.0 | 6.1.7 |
| `org.springframework.security:spring-security-core` | Maven | From 6.2.0 | 6.2.2 |
| `org.springframework.security:spring-security-core` | Maven | From 6.2.0 | 6.2.2 |

Products: Vmware Spring Security.

## How do I fix CVE-2024-22234?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 6.1.7 or 6.2.2.

## Is CVE-2024-22234 being exploited?

There is no known exploitation of CVE-2024-22234 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22234 and fix it if it is affected.

What it is: CVE-2024-22234 is a high-severity authentication bypass vulnerability in Spring Security, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22234 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 6.1.0; fixed in 6.1.7
- org.springframework.security:spring-security-core (Maven): affected from 6.1.0; fixed in 6.1.7
- org.springframework.security:spring-security-core (Maven): affected from 6.2.0; fixed in 6.2.2
- org.springframework.security:spring-security-core (Maven): affected from 6.2.0; fixed in 6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22234/ (Markdown: https://insights.sbomify.com/CVE-2024-22234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22234
- OSV: https://osv.dev/vulnerability/CVE-2024-22234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22234/
Summaries are generated and may contain mistakes; the official description above is the record.
