# CVE-2024-22243: CVE-2024-22243: Spring Framework URL Parsing with Host Validation

> Attackers can bypass host validation in Spring Framework to perform open redirects or SSRF attacks when parsing external URLs.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** CLSA-2026-1773274547, DEBIAN-CVE-2024-22243, ECHO-6aef-bc09-6cff, GHSA-ccgv-vj62-xf9h, ROOT-APP-MAVEN-CVE-2024-22243, UBUNTU-CVE-2024-22243

## What is CVE-2024-22243?

CVE-2024-22243 is a high-severity vulnerability in Spring Framework, published on 23 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Applications that use UriComponentsBuilder to parse an externally provided URL (e.g. through a query parameter) AND perform validation checks on the host of the parsed URL may be vulnerable to a  open redirect https://cwe.mitre.org/data/definitions/601.html  attack or to a SSRF attack if the URL is used after passing validation checks.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2024-22243?

8 open source packages ship an affected version, including org.springframework:spring-web.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-web` | Maven | All versions to 5.2.25.RELEASE | None |
| `org.springframework:spring-web` | Maven | All versions to 5.2.25.RELEASE | None |
| `org.springframework:spring-web` | Maven | From 5.3.0 | 5.3.32 |
| `org.springframework:spring-web` | Maven | From 5.3.0 | 5.3.32 |
| `org.springframework:spring-web` | Maven | From 6.0.0 | 6.0.17 |
| `org.springframework:spring-web` | Maven | From 6.0.0 | 6.0.17 |
| `org.springframework:spring-web` | Maven | From 6.1.0 | 6.1.4 |
| `org.springframework:spring-web` | Maven | From 6.1.0 | 6.1.4 |

## How do I fix CVE-2024-22243?

Upgrade org.springframework:spring-web to a fixed version for your release line: 5.3.32, 6.0.17 or 6.1.4.

## Is CVE-2024-22243 being exploited?

There is no known exploitation of CVE-2024-22243 in the wild and no public exploit code.

Public exploit code:

- Example exploitable scenarios for CVE-2024-22243 affecting the Spring framework (open redirect & SSRF). (github_poc): https://github.com/SeanPesce/CVE-2024-22243
-  env of CVE-2024-22243&CVE-2024-22234 (github_poc): https://github.com/shellfeel/CVE-2024-22243-CVE-2024-22234
- Code used from @SeanPesce (github_poc): https://github.com/Reivap/CVE-2024-22243

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22243 and fix it if it is affected.

What it is: CVE-2024-22243 is a high-severity vulnerability in Spring Framework, published on 23 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-22243 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-web (Maven): affected all versions up to 5.2.25.RELEASE; no fix listed
- org.springframework:spring-web (Maven): affected all versions up to 5.2.25.RELEASE; no fix listed
- org.springframework:spring-web (Maven): affected from 5.3.0; fixed in 5.3.32
- org.springframework:spring-web (Maven): affected from 5.3.0; fixed in 5.3.32
- org.springframework:spring-web (Maven): affected from 6.0.0; fixed in 6.0.17
- org.springframework:spring-web (Maven): affected from 6.0.0; fixed in 6.0.17
- org.springframework:spring-web (Maven): affected from 6.1.0; fixed in 6.1.4
- org.springframework:spring-web (Maven): affected from 6.1.0; fixed in 6.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22243/ (Markdown: https://insights.sbomify.com/CVE-2024-22243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22243
- OSV: https://osv.dev/vulnerability/CVE-2024-22243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22243/
Summaries are generated and may contain mistakes; the official description above is the record.
