# CVE-2024-22244: Harbor Open Redirect URL

> Attackers can redirect users to malicious sites via crafted URLs in Harbor, potentially facilitating phishing attacks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-harbor-2024-22244, GHSA-5757-v49g-f6r7, GO-2024-2915

## What is CVE-2024-22244?

CVE-2024-22244 is a medium-severity vulnerability in Harbor, published on 10 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open Redirect in Harbor  <=v2.8.4, <=v2.9.2, and <=v2.10.0 may redirect a user to a malicious site.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2024-22244?

8 open source packages ship an affected version, including github.com/goharbor/harbor and harbor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/goharbor/harbor` | Go | All versions | 2.8.5+incompatible, 2.9.3+incompatible, 2.10.1+incompatible |
| `github.com/goharbor/harbor` | Go | All versions | 2.8.5 |
| `github.com/goharbor/harbor` | Go | All versions | 2.8.5 |
| `github.com/goharbor/harbor` | Go | From 2.10.0 | 2.10.1 |
| `github.com/goharbor/harbor` | Go | From 2.10.0 | 2.10.1 |
| `github.com/goharbor/harbor` | Go | From 2.9.0 | 2.9.3 |
| `github.com/goharbor/harbor` | Go | From 2.9.0 | 2.9.3 |
| `harbor` | Bitnami | From 2.8.0 | 2.8.5, 2.9.3, 2.10.2 |

Products: Linuxfoundation Harbor.

## How do I fix CVE-2024-22244?

Upgrade github.com/goharbor/harbor to a fixed version for your release line: 2.8.5+incompatible, 2.9.3+incompatible, 2.10.1+incompatible or 2.8.5.

## Is CVE-2024-22244 being exploited?

There is no known exploitation of CVE-2024-22244 in the wild and no public exploit code.

## Other vulnerabilities in Harbor

- [CVE-2026-4404](https://insights.sbomify.com/CVE-2026-4404/): Use of hard coded credentials in GoHarbor Harbor (critical 9.4)
- [CVE-2019-19023](https://insights.sbomify.com/CVE-2019-19023/): Privilege Escalation in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2019-19025](https://insights.sbomify.com/CVE-2019-19025/): Cross-site Request Forgery (CSRF) in Cloud Native Computing Foundation Harbor (high 8.8)
- [CVE-2017-17697](https://insights.sbomify.com/CVE-2017-17697/): Server-side request forgery in n/a (high 8.6)
- [CVE-2022-31666](https://insights.sbomify.com/CVE-2022-31666/): Harbor fails to validate user permissions while Viewing, updating and deleting Webhook policies (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22244 and fix it if it is affected.

What it is: CVE-2024-22244 is a medium-severity vulnerability in Harbor, published on 10 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-22244 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/goharbor/harbor (Go): affected all versions; fixed in 2.8.5+incompatible, 2.9.3+incompatible, 2.10.1+incompatible
- github.com/goharbor/harbor (Go): affected all versions; fixed in 2.8.5
- github.com/goharbor/harbor (Go): affected all versions; fixed in 2.8.5
- github.com/goharbor/harbor (Go): affected from 2.10.0; fixed in 2.10.1
- github.com/goharbor/harbor (Go): affected from 2.10.0; fixed in 2.10.1
- github.com/goharbor/harbor (Go): affected from 2.9.0; fixed in 2.9.3
- github.com/goharbor/harbor (Go): affected from 2.9.0; fixed in 2.9.3
- harbor (Bitnami): affected from 2.8.0; fixed in 2.8.5, 2.9.3, 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22244/ (Markdown: https://insights.sbomify.com/CVE-2024-22244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22244
- OSV: https://osv.dev/vulnerability/CVE-2024-22244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22244/
Summaries are generated and may contain mistakes; the official description above is the record.
