{"answers":{"affected":"8 open source packages ship an affected version, including org.springframework.security:spring-security-core.","exploited":"There is no known exploitation of CVE-2024-22257 in the wild and no public exploit code.","fix":"Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 5.7.12, 5.8.11, 6.1.8 or 6.2.3.","what":"CVE-2024-22257 is a high-severity missing authorization vulnerability in Spring Security, published on 18 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-22257 and fix it if it is affected.\n\nWhat it is: CVE-2024-22257 is a high-severity missing authorization vulnerability in Spring Security, published on 18 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-22257 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 5.7.12\n- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 5.7.12\n- org.springframework.security:spring-security-core (Maven): affected from 5.8.0; fixed in 5.8.11\n- org.springframework.security:spring-security-core (Maven): affected from 5.8.0; fixed in 5.8.11\n- org.springframework.security:spring-security-core (Maven): affected from 6.0.0; fixed in 6.1.8\n- org.springframework.security:spring-security-core (Maven): affected from 6.0.0; fixed in 6.1.8\n- org.springframework.security:spring-security-core (Maven): affected from 6.2.0; fixed in 6.2.3\n- org.springframework.security:spring-security-core (Maven): affected from 6.2.0; fixed in 6.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22257/ (Markdown: https://insights.sbomify.com/CVE-2024-22257/index.md)","id":"CVE-2024-22257","markdown":"https://insights.sbomify.com/CVE-2024-22257/index.md","name":"CVE-2024-22257","record":{"aliases":["CLEANSTART-2026-WY50072","CLSA-2024-1727308812","ECHO-a103-74de-c83b","GHSA-f3jh-qvm4-mg39","RHLW-2026-779e7aa7bc83a4c5","ROOT-APP-MAVEN-CVE-2024-22257"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Java security library","requires_auth":"none","summary":"Developers using Spring Security must upgrade to prevent broken access control when AuthenticatedVoter#vote is called with null authentication.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"In Spring Security, versions 5.7.x prior to 5.7.12, 5.8.x prior to \n5.8.11, versions 6.0.x prior to 6.0.9, versions 6.1.x prior to 6.1.8, \nversions 6.2.x prior to 6.2.3, an application is possible vulnerable to \nbroken access control when it directly uses the AuthenticatedVoter#vote passing a null Authentication parameter.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Erroneous authentication pass in Spring Security","id":"CVE-2024-22257","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":8,"n_references":2,"next":{"headline":"CVE-2024-22258: PKCE Downgrade in Spring Authorization Server","id":"CVE-2024-22258"},"packages":[{"ecosystem":"Maven","fixed":["5.7.12"],"introduced":["0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":null,"source":"GHSA-f3jh-qvm4-mg39"},{"ecosystem":"Maven","fixed":["5.7.12"],"introduced":["0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":"pkg:maven/org.springframework.security/spring-security-core","source":"GHSA-f3jh-qvm4-mg39"},{"ecosystem":"Maven","fixed":["5.8.11"],"introduced":["5.8.0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":null,"source":"GHSA-f3jh-qvm4-mg39"},{"ecosystem":"Maven","fixed":["5.8.11"],"introduced":["5.8.0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":"pkg:maven/org.springframework.security/spring-security-core","source":"GHSA-f3jh-qvm4-mg39"},{"ecosystem":"Maven","fixed":["6.1.8"],"introduced":["6.0.0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":null,"source":"GHSA-f3jh-qvm4-mg39"},{"ecosystem":"Maven","fixed":["6.1.8"],"introduced":["6.0.0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":"pkg:maven/org.springframework.security/spring-security-core","source":"GHSA-f3jh-qvm4-mg39"},{"ecosystem":"Maven","fixed":["6.2.3"],"introduced":["6.2.0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":null,"source":"GHSA-f3jh-qvm4-mg39"},{"ecosystem":"Maven","fixed":["6.2.3"],"introduced":["6.2.0"],"last_affected":[],"package":"org.springframework.security:spring-security-core","purl":"pkg:maven/org.springframework.security/spring-security-core","source":"GHSA-f3jh-qvm4-mg39"}],"prev":{"headline":"Information disclosure in VMware Cloud Director","id":"CVE-2024-22256"},"products":["Spring Security"],"published":"2024-03-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-30","vendors":["N/A"]},"summary":"Developers using Spring Security must upgrade to prevent broken access control when AuthenticatedVoter#vote is called with null authentication.","url":"https://insights.sbomify.com/CVE-2024-22257/"}