{"answers":{"affected":"4 open source packages ship an affected version, including org.springframework.security:spring-security-oauth2-authorization-server.","exploited":"There is no known exploitation of CVE-2024-22258 in the wild and no public exploit code.","fix":"Upgrade org.springframework.security:spring-security-oauth2-authorization-server to a fixed version for your release line: 1.1.6 or 1.2.3.","what":"CVE-2024-22258 is a medium-severity vulnerability in Spring, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-22258 and fix it if it is affected.\n\nWhat it is: CVE-2024-22258 is a medium-severity vulnerability in Spring, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-22258 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected all versions; fixed in 1.1.6\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected all versions; fixed in 1.1.6\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 1.2.0; fixed in 1.2.3\n- org.springframework.security:spring-security-oauth2-authorization-server (Maven): affected from 1.2.0; fixed in 1.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22258/ (Markdown: https://insights.sbomify.com/CVE-2024-22258/index.md)","id":"CVE-2024-22258","markdown":"https://insights.sbomify.com/CVE-2024-22258/index.md","name":"CVE-2024-22258","record":{"aliases":["CLSA-2026-1768522124","GHSA-x637-x8p3-5p22","ROOT-APP-MAVEN-CVE-2024-22258","UBUNTU-CVE-2024-22258"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Spring Authorization Server","requires_auth":"none","summary":"Attackers can bypass PKCE protection for confidential clients using the Authorization Code Grant, potentially compromising authentication security.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients.\n\nSpecifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant.\n\nAn application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CVE-2024-22258: PKCE Downgrade in Spring Authorization Server","id":"CVE-2024-22258","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":4,"n_references":1,"next":{"headline":"CVE-2024-22259: Spring Framework URL Parsing with Host Validation (2nd report)","id":"CVE-2024-22259"},"packages":[{"ecosystem":"Maven","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":null,"source":"GHSA-x637-x8p3-5p22"},{"ecosystem":"Maven","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":"pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server","source":"GHSA-x637-x8p3-5p22"},{"ecosystem":"Maven","fixed":["1.2.3"],"introduced":["1.2.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":null,"source":"GHSA-x637-x8p3-5p22"},{"ecosystem":"Maven","fixed":["1.2.3"],"introduced":["1.2.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-authorization-server","purl":"pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server","source":"GHSA-x637-x8p3-5p22"}],"prev":{"headline":"Erroneous authentication pass in Spring Security","id":"CVE-2024-22257"},"products":["Spring"],"published":"2024-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-05","vendors":["Spring"]},"summary":"Attackers can bypass PKCE protection for confidential clients using the Authorization Code Grant, potentially compromising authentication security.","url":"https://insights.sbomify.com/CVE-2024-22258/"}