{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22368 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-22368 is a medium-severity denial of service vulnerability in n/a, published on 9 Jan 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-22368 and fix it if it is affected.\n\nWhat it is: CVE-2024-22368 is a medium-severity denial of service vulnerability in n/a, published on 9 Jan 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22368 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22368/ (Markdown: https://insights.sbomify.com/CVE-2024-22368/index.md)","id":"CVE-2024-22368","markdown":"https://insights.sbomify.com/CVE-2024-22368/index.md","name":"CVE-2024-22368","record":{"aliases":["DEBIAN-CVE-2024-22368","GHSA-x2hg-844v-frvh","UBUNTU-CVE-2024-22368","openSUSE-SU-2024:0021-1","openSUSE-SU-2024:13584-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Perl XLSX parser","requires_auth":"none","summary":"An attacker can cause a denial of service via out-of-memory condition by providing a crafted XLSX document to the Perl Spreadsheet::ParseXLSX library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"spreadsheet\\","vendor":"tozt"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"The Spreadsheet::ParseXLSX package before 0.28 for Perl can encounter an out-of-memory condition during parsing of a crafted XLSX document. This occurs because the memoize implementation does not have appropriate constraints on merged cells.","ecosystems":["SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2024-22368","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":7,"next":{"headline":"Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository","id":"CVE-2024-22369"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["0.290.0-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-Spreadsheet-ParseXLSX","purl":"pkg:rpm/suse/perl-Spreadsheet-ParseXLSX\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0021-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["0.290.0-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-Spreadsheet-ParseXLSX","purl":"pkg:rpm/opensuse/perl-Spreadsheet-ParseXLSX\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0021-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.290.0-2.1"],"introduced":["0"],"last_affected":[],"package":"perl-Spreadsheet-ParseXLSX","purl":"pkg:rpm/opensuse/perl-Spreadsheet-ParseXLSX\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13584-1"}],"prev":{"headline":"Command injection in WLX202","id":"CVE-2024-22366"},"products":["n/a"],"published":"2024-01-09","related":[{"cvss_score":6.5,"headline":"XML external entity in n/a","id":"CVE-2024-23525","kev_date_added":null,"published":"2024-01-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"An attacker can cause a denial of service via out-of-memory condition by providing a crafted XLSX document to the Perl Spreadsheet::ParseXLSX library.","url":"https://insights.sbomify.com/CVE-2024-22368/"}