CVE-2024-22369 Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository
An attacker can execute arbitrary code via unsafe deserialization in the Apache Camel SQL component's JDBCAggregationRepository.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-22369?
CVE-2024-22369 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 20 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.
Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
Weakness: CWE-502
Which versions are affected by CVE-2024-22369?
8 open source packages ship an affected version, including org.apache.camel:camel-sql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-sql Maven | From 3.0.0 | 3.21.4 |
org.apache.camel:camel-sql Maven | From 3.0.0 | 3.21.4 |
org.apache.camel:camel-sql Maven | From 3.22.0 | 3.22.1 |
org.apache.camel:camel-sql Maven | From 3.22.0 | 3.22.1 |
org.apache.camel:camel-sql Maven | From 4.0.0 | 4.0.4 |
org.apache.camel:camel-sql Maven | From 4.0.0 | 4.0.4 |
2 more packages
org.apache.camel:camel-sql Maven | From 4.1.0 | 4.4.0 |
org.apache.camel:camel-sql Maven | From 4.1.0 | 4.4.0 |
Products include Apache Camel.
How do I fix CVE-2024-22369?
Upgrade org.apache.camel:camel-sql to a fixed version for your release line: 3.21.4, 3.22.1, 4.0.4 or 4.4.0.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2024-22369 being exploited?
There is no known exploitation of CVE-2024-22369 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as GHSA-36xr-4x2f-cfj9.