# CVE-2024-22369: Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

> An attacker can execute arbitrary code via unsafe deserialization in the Apache Camel SQL component's JDBCAggregationRepository.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 5 Nov 2024
- **Also known as:** GHSA-36xr-4x2f-cfj9

## What is CVE-2024-22369?

CVE-2024-22369 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 20 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-22369?

8 open source packages ship an affected version, including org.apache.camel:camel-sql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-sql` | Maven | From 3.0.0 | 3.21.4 |
| `org.apache.camel:camel-sql` | Maven | From 3.0.0 | 3.21.4 |
| `org.apache.camel:camel-sql` | Maven | From 3.22.0 | 3.22.1 |
| `org.apache.camel:camel-sql` | Maven | From 3.22.0 | 3.22.1 |
| `org.apache.camel:camel-sql` | Maven | From 4.0.0 | 4.0.4 |
| `org.apache.camel:camel-sql` | Maven | From 4.0.0 | 4.0.4 |
| `org.apache.camel:camel-sql` | Maven | From 4.1.0 | 4.4.0 |
| `org.apache.camel:camel-sql` | Maven | From 4.1.0 | 4.4.0 |

Products: Apache Camel.

## How do I fix CVE-2024-22369?

Upgrade org.apache.camel:camel-sql to a fixed version for your release line: 3.21.4, 3.22.1, 4.0.4 or 4.4.0.

## Is CVE-2024-22369 being exploited?

There is no known exploitation of CVE-2024-22369 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-22369 Reproducer (github_poc): https://github.com/oscerd/CVE-2024-22369

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22369 and fix it if it is affected.

What it is: CVE-2024-22369 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 20 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-22369 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-sql (Maven): affected from 3.0.0; fixed in 3.21.4
- org.apache.camel:camel-sql (Maven): affected from 3.0.0; fixed in 3.21.4
- org.apache.camel:camel-sql (Maven): affected from 3.22.0; fixed in 3.22.1
- org.apache.camel:camel-sql (Maven): affected from 3.22.0; fixed in 3.22.1
- org.apache.camel:camel-sql (Maven): affected from 4.0.0; fixed in 4.0.4
- org.apache.camel:camel-sql (Maven): affected from 4.0.0; fixed in 4.0.4
- org.apache.camel:camel-sql (Maven): affected from 4.1.0; fixed in 4.4.0
- org.apache.camel:camel-sql (Maven): affected from 4.1.0; fixed in 4.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22369/ (Markdown: https://insights.sbomify.com/CVE-2024-22369/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22369
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22369
- OSV: https://osv.dev/vulnerability/CVE-2024-22369

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22369/
Summaries are generated and may contain mistakes; the official description above is the record.
