# CVE-2024-22399: Apache Seata: Remote Code Execution vulnerability via Hessian Deserialization in Apache Seata Server

> Attackers can achieve remote code execution by sending malicious serialized requests if authentication is disabled on the Seata Server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2024
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3xq2-w6j4-c99r

## What is CVE-2024-22399?

CVE-2024-22399 is a critical unsafe deserialization vulnerability in Apache Seata, published on 16 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Apache Seata. 

When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol.

This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0.

Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-22399?

4 open source packages ship an affected version, including org.apache.seata:seata-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.seata:seata-core` | Maven | From 1.0.0 | 1.8.1 |
| `org.apache.seata:seata-core` | Maven | From 1.0.0 | 1.8.1 |
| `org.apache.seata:seata-core` | Maven | From 2.0.0 | 2.1.0 |
| `org.apache.seata:seata-core` | Maven | From 2.0.0 | 2.1.0 |

Products: Apache Seata.

## How do I fix CVE-2024-22399?

Upgrade org.apache.seata:seata-core to a fixed version for your release line: 1.8.1 or 2.1.0.

## Is CVE-2024-22399 being exploited?

There is no known exploitation of CVE-2024-22399 in the wild and no public exploit code.

## Other vulnerabilities in Apache Seata

- [CVE-2025-53606](https://insights.sbomify.com/CVE-2025-53606/): Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server (critical 9.8)
- [CVE-2025-32897](https://insights.sbomify.com/CVE-2025-32897/): Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server (critical 9.8)
- [CVE-2024-47552](https://insights.sbomify.com/CVE-2024-47552/): Apache Seata (incubating): Deserialization of untrusted Data in jraft mode in Apache Seata Server (critical 9.8)
- [CVE-2024-54016](https://insights.sbomify.com/CVE-2024-54016/): compression bomb attack in Apache Seata Server (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22399 and fix it if it is affected.

What it is: CVE-2024-22399 is a critical unsafe deserialization vulnerability in Apache Seata, published on 16 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22399 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.seata:seata-core (Maven): affected from 1.0.0; fixed in 1.8.1
- org.apache.seata:seata-core (Maven): affected from 1.0.0; fixed in 1.8.1
- org.apache.seata:seata-core (Maven): affected from 2.0.0; fixed in 2.1.0
- org.apache.seata:seata-core (Maven): affected from 2.0.0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22399/ (Markdown: https://insights.sbomify.com/CVE-2024-22399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22399
- OSV: https://osv.dev/vulnerability/CVE-2024-22399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22399/
Summaries are generated and may contain mistakes; the official description above is the record.
