CVE-2024-22407 Broken Access Control order API in Shopware
Attackers without write permissions can modify order, payment, and delivery statuses in Shopware due to broken access control.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-22407?
CVE-2024-22407 is a medium-severity missing authorization vulnerability in Shopware Shopware, published on 16 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Shopware is an open headless commerce platform. In the Shopware CMS, the state handler for orders fails to sufficiently verify user authorizations for actions that modify the payment, delivery, and/or order status. Due to this inadequate implementation, users lacking 'write' permissions for orders are still able to change the order state. This issue has been addressed and users are advised to update to Shopware 6.5.7.4. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Weakness: CWE-284
Which versions are affected by CVE-2024-22407?
4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.5.7.4 |
shopware/core Packagist | All versions | 6.5.7.4 |
shopware/platform Packagist | All versions | 6.5.7.4 |
shopware/platform Packagist | All versions | 6.5.7.4 |
Products include Shopware Shopware.
How do I fix CVE-2024-22407?
Upgrade shopware/core to 6.5.7.4 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-22407 being exploited?
There is no known exploitation of CVE-2024-22407 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-3867-jc5c-66qf.