# CVE-2024-22407: Broken Access Control order API in Shopware

> Attackers without write permissions can modify order, payment, and delivery statuses in Shopware due to broken access control.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2024
- **Updated:** 13 Nov 2024
- **Also known as:** GHSA-3867-jc5c-66qf

## What is CVE-2024-22407?

CVE-2024-22407 is a medium-severity missing authorization vulnerability in Shopware Shopware, published on 16 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Shopware is an open headless commerce platform. In the Shopware CMS, the state handler for orders fails to sufficiently verify user authorizations for actions that modify the payment, delivery, and/or order status. Due to this inadequate implementation, users lacking 'write' permissions for orders are still able to change the order state. This issue has been addressed and users are advised to update to Shopware 6.5.7.4. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-22407?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.5.7.4 |
| `shopware/core` | Packagist | All versions | 6.5.7.4 |
| `shopware/platform` | Packagist | All versions | 6.5.7.4 |
| `shopware/platform` | Packagist | All versions | 6.5.7.4 |

Products: Shopware Shopware.

## How do I fix CVE-2024-22407?

Upgrade shopware/core to 6.5.7.4 or later.

## Is CVE-2024-22407 being exploited?

There is no known exploitation of CVE-2024-22407 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22407 and fix it if it is affected.

What it is: CVE-2024-22407 is a medium-severity missing authorization vulnerability in Shopware Shopware, published on 16 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22407 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.5.7.4
- shopware/core (Packagist): affected all versions; fixed in 6.5.7.4
- shopware/platform (Packagist): affected all versions; fixed in 6.5.7.4
- shopware/platform (Packagist): affected all versions; fixed in 6.5.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22407/ (Markdown: https://insights.sbomify.com/CVE-2024-22407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22407
- OSV: https://osv.dev/vulnerability/CVE-2024-22407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22407/
Summaries are generated and may contain mistakes; the official description above is the record.
