# CVE-2024-22408: Server-Side Request Forgery (SSRF) in Shopware Flow Builder

> Attackers can exploit inadequate URL validation in Shopware Flow Builder to perform server-side requests to internal hosts.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-3535-m8vh-vrmw

## What is CVE-2024-22408?

CVE-2024-22408 is a high-severity server-side request forgery vulnerability in Shopware Shopware, published on 16 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Shopware is an open headless commerce platform. The implemented Flow Builder functionality in the Shopware application does not adequately validate the URL used when creating the “call webhook” action. This enables malicious users to perform web requests to internal hosts. This issue has been fixed in the Commercial Plugin release 6.5.7.4 or with the Security Plugin. For installations with Shopware 6.4 the Security plugin is recommended to be installed and up to date. For older versions of 6.4 and 6.5 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-22408?

It affects 1 product.


Products: Shopware Shopware.

## How do I fix CVE-2024-22408?

No fix has been published for CVE-2024-22408 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-22408 being exploited?

There is no known exploitation of CVE-2024-22408 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22408 and fix it if it is affected.

What it is: CVE-2024-22408 is a high-severity server-side request forgery vulnerability in Shopware Shopware, published on 16 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22408 in the wild and no public exploit code.

Affected product: Shopware Shopware. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22408/ (Markdown: https://insights.sbomify.com/CVE-2024-22408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22408
- OSV: https://osv.dev/vulnerability/CVE-2024-22408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22408/
Summaries are generated and may contain mistakes; the official description above is the record.
