{"answers":{"affected":"3 open source packages ship an affected version, including jupyter-lsp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-22415 in the wild and no public exploit code.","fix":"Upgrade jupyter-lsp to 2.2.2 or later.","what":"CVE-2024-22415 is a high-severity path traversal vulnerability in jupyter-lsp jupyterlab-lsp, published on 18 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-22415 and fix it if it is affected.\n\nWhat it is: CVE-2024-22415 is a high-severity path traversal vulnerability in jupyter-lsp jupyterlab-lsp, published on 18 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-22415 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyter-lsp (PyPI): affected all versions; fixed in 2.2.2\n- jupyter-lsp (PyPI): affected all versions; fixed in 2.2.2\n- jupyter-lsp (PyPI): affected all versions; fixed in 2.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22415/ (Markdown: https://insights.sbomify.com/CVE-2024-22415/index.md)","id":"CVE-2024-22415","markdown":"https://insights.sbomify.com/CVE-2024-22415/index.md","name":"CVE-2024-22415","record":{"aliases":["GHSA-4qhp-652w-c22x","PYSEC-2026-1478","openSUSE-SU-2024:13601-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterLab LSP extension","requires_auth":"none","summary":"Attackers can access and modify files outside the Jupyter root directory if the server is exposed to untrusted networks without OS-level access controls.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"language_server_protocol_integration","vendor":"jupyter"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"jupyter-lsp is a coding assistance tool for JupyterLab (code navigation + hover suggestions + linters + autocompletion + rename) using Language Server Protocol. Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. This issue has been patched in version 2.2.2 and all users are advised to upgrade. Users unable to upgrade should uninstall jupyter-lsp.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsecured endpoints in the jupyter-lsp server extension","id":"CVE-2024-22415","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation","id":"CVE-2024-22416"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"jupyter-lsp","purl":null,"source":"GHSA-4qhp-652w-c22x"},{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"jupyter-lsp","purl":"pkg:pypi/jupyter-lsp","source":"GHSA-4qhp-652w-c22x"},{"ecosystem":"PyPI","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"jupyter-lsp","purl":"pkg:pypi/jupyter-lsp","source":"PYSEC-2026-1478"}],"prev":{"headline":"User profile page vulnerable to Cross Site Scripting (XSS) in flaskBlog","id":"CVE-2024-22414"},"products":["jupyterlab-lsp"],"published":"2024-01-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-10","vendors":["jupyter-lsp"]},"summary":"Attackers can access and modify files outside the Jupyter root directory if the server is exposed to untrusted networks without OS-level access controls.","url":"https://insights.sbomify.com/CVE-2024-22415/"}