# CVE-2024-22415: Unsecured endpoints in the jupyter-lsp server extension

> Attackers can access and modify files outside the Jupyter root directory if the server is exposed to untrusted networks without OS-level access controls.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2024
- **Updated:** 10 Sep 2024
- **Also known as:** GHSA-4qhp-652w-c22x, PYSEC-2026-1478, openSUSE-SU-2024:13601-1

## What is CVE-2024-22415?

CVE-2024-22415 is a high-severity path traversal vulnerability in jupyter-lsp jupyterlab-lsp, published on 18 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jupyter-lsp is a coding assistance tool for JupyterLab (code navigation + hover suggestions + linters + autocompletion + rename) using Language Server Protocol. Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. This issue has been patched in version 2.2.2 and all users are advised to upgrade. Users unable to upgrade should uninstall jupyter-lsp.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-306 (Missing Authentication for Critical Functionality), CWE-284 (Improper Access Control), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2024-22415?

3 open source packages ship an affected version, including jupyter-lsp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-lsp` | PyPI | All versions | 2.2.2 |
| `jupyter-lsp` | PyPI | All versions | 2.2.2 |
| `jupyter-lsp` | PyPI | All versions | 2.2.2 |

Products: Jupyter Language Server Protocol Integration.

## How do I fix CVE-2024-22415?

Upgrade jupyter-lsp to 2.2.2 or later.

## Is CVE-2024-22415 being exploited?

There is no known exploitation of CVE-2024-22415 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22415 and fix it if it is affected.

What it is: CVE-2024-22415 is a high-severity path traversal vulnerability in jupyter-lsp jupyterlab-lsp, published on 18 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22415 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-lsp (PyPI): affected all versions; fixed in 2.2.2
- jupyter-lsp (PyPI): affected all versions; fixed in 2.2.2
- jupyter-lsp (PyPI): affected all versions; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22415/ (Markdown: https://insights.sbomify.com/CVE-2024-22415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22415
- OSV: https://osv.dev/vulnerability/CVE-2024-22415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22415/
Summaries are generated and may contain mistakes; the official description above is the record.
