# CVE-2024-22416: Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation

> Unauthenticated attackers can perform CSRF attacks on pyLoad API calls to escalate privileges due to missing SameSite cookie restrictions.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-pgpj-v85q-h5fm, PYSEC-2024-17

## What is CVE-2024-22416?

CVE-2024-22416 is a critical vulnerability in pyload, published on 17 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pyLoad is a free and open-source Download Manager written in pure Python. The `pyload` API allows any API call to be made using GET requests. Since the session cookie is not set to `SameSite: strict`, this opens the library up to severe attack possibilities via a Cross-Site Request Forgery (CSRF) attack. As a result any API call can be made via a CSRF attack by an unauthenticated user. This issue has been addressed in release `0.5.0b3.dev78`. All users are advised to upgrade.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-22416?

3 open source packages ship an affected version, including pyload-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev78 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev78 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev78 |

Products: Pyload-Ng Project Pyload-Ng.

## How do I fix CVE-2024-22416?

Upgrade pyload-ng to 0.5.0b3.dev78 or later.

## Is CVE-2024-22416 being exploited?

There is no known exploitation of CVE-2024-22416 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-22416 exploit experiments (github_poc): https://github.com/theorzr/ensimag-secu3a-cve-2024-22416

## Other vulnerabilities in pyload

- [CVE-2025-54802](https://insights.sbomify.com/CVE-2025-54802/): pyLoad CNL Blueprint is vulnerable to Path Traversal through `dlc_path` leading to Remote Code Execution (RCE) (critical 9.8)
- [CVE-2023-0488](https://insights.sbomify.com/CVE-2023-0488/): Cross-site Scripting (XSS) - Stored in pyload/pyload (critical 9.6)
- [CVE-2026-35459](https://insights.sbomify.com/CVE-2026-35459/): pyLoad has SSRF fix bypass via HTTP redirect (critical 9.3)
- [CVE-2026-35463](https://insights.sbomify.com/CVE-2026-35463/): pyLoad has Improper Neutralization of Special Elements used in an OS Command (high 8.8)
- [CVE-2026-33511](https://insights.sbomify.com/CVE-2026-33511/): pyload-ng: Authentication Bypass via Host Header Injection in ClickNLoad (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22416 and fix it if it is affected.

What it is: CVE-2024-22416 is a critical vulnerability in pyload, published on 17 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-22416 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev78
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev78
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22416/ (Markdown: https://insights.sbomify.com/CVE-2024-22416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22416
- OSV: https://osv.dev/vulnerability/CVE-2024-22416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22416/
Summaries are generated and may contain mistakes; the official description above is the record.
