{"answers":{"affected":"3 open source packages ship an affected version, including whoogle-search. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22417 exists.","fix":"Upgrade whoogle-search to 0.8.4 or later.","what":"CVE-2024-22417 is a medium-severity cross-site scripting vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-22417 and fix it if it is affected.\n\nWhat it is: CVE-2024-22417 is a medium-severity cross-site scripting vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22417 exists.\n\nAffected packages and fixed versions:\n- whoogle-search (PyPI): affected all versions; fixed in 0.8.4\n- whoogle-search (PyPI): affected all versions; fixed in 0.8.4\n- whoogle-search (PyPI): affected all versions; fixed in 0.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22417/ (Markdown: https://insights.sbomify.com/CVE-2024-22417/index.md)","id":"CVE-2024-22417","markdown":"https://insights.sbomify.com/CVE-2024-22417/index.md","name":"CVE-2024-22417","record":{"aliases":["GHSA-phg6-44m7-hx3h","PYSEC-2024-19"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Whoogle Search","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victims' browsers via crafted URLs, potentially stealing credentials or session data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"whoogle_search","vendor":"benbusby"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Whoogle Search is a self-hosted metasearch engine. In versions 0.8.3 and prior, the `element` method in `app/routes.py` does not validate the user-controlled `src_type` and `element_url` variables and passes them to the `send` method which sends a `GET` request on lines 339-343 in `requests.py`. The returned contents of the URL are then passed to and reflected back to the user in the `send_file` function on line 484, together with the user-controlled `src_type`, which allows the attacker to control the HTTP response content type leading to a cross-site scripting vulnerability. An attacker could craft a special URL to point to a malicious website and send the link to a victim. The fact that the link would contain a trusted domain (e.g. from one of public Whoogle instances) could be used to trick the user into clicking the link. The malicious website could, for example, be a copy of a real website, meant to steal a person’s credentials to the website, or trick that person in another way. Version 0.8.4 contains a patch for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Whoogle Search Cross-site Scripting vulnerability","id":"CVE-2024-22417","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":3,"n_references":8,"next":{"headline":"Stored Cross-site Scripting Vulnerability via Malicious File Names in GroupOffice","id":"CVE-2024-22418"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":null,"source":"GHSA-phg6-44m7-hx3h"},{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"GHSA-phg6-44m7-hx3h"},{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"whoogle-search","purl":"pkg:pypi/whoogle-search","source":"PYSEC-2024-19"}],"prev":{"headline":"Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation","id":"CVE-2024-22416"},"products":["whoogle-search"],"published":"2024-01-23","related":[{"cvss_score":9.1,"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22203","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":9.1,"headline":"Whoogle Search Server Side Request Forgery vulnerability","id":"CVE-2024-22205","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":7.3,"headline":"Whoogle allows attackers to execute arbitrary code via supplying a crafted search query","id":"CVE-2024-53305","kev_date_added":null,"published":"2025-04-16"},{"cvss_score":5.3,"headline":"Whoogle Search Limited File Write vulnerability","id":"CVE-2024-22204","kev_date_added":null,"published":"2024-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["benbusby"]},"summary":"Attackers can execute arbitrary scripts in victims' browsers via crafted URLs, potentially stealing credentials or session data.","url":"https://insights.sbomify.com/CVE-2024-22417/"}