# CVE-2024-22417: Whoogle Search Cross-site Scripting vulnerability

> Attackers can execute arbitrary scripts in victims' browsers via crafted URLs, potentially stealing credentials or session data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-phg6-44m7-hx3h, PYSEC-2024-19

## What is CVE-2024-22417?

CVE-2024-22417 is a medium-severity cross-site scripting vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Whoogle Search is a self-hosted metasearch engine. In versions 0.8.3 and prior, the `element` method in `app/routes.py` does not validate the user-controlled `src_type` and `element_url` variables and passes them to the `send` method which sends a `GET` request on lines 339-343 in `requests.py`. The returned contents of the URL are then passed to and reflected back to the user in the `send_file` function on line 484, together with the user-controlled `src_type`, which allows the attacker to control the HTTP response content type leading to a cross-site scripting vulnerability. An attacker could craft a special URL to point to a malicious website and send the link to a victim. The fact that the link would contain a trusted domain (e.g. from one of public Whoogle instances) could be used to trick the user into clicking the link. The malicious website could, for example, be a copy of a real website, meant to steal a person’s credentials to the website, or trick that person in another way. Version 0.8.4 contains a patch for this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-22417?

3 open source packages ship an affected version, including whoogle-search. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `whoogle-search` | PyPI | All versions | 0.8.4 |
| `whoogle-search` | PyPI | All versions | 0.8.4 |
| `whoogle-search` | PyPI | All versions | 0.8.4 |

Products: Benbusby Whoogle Search.

## How do I fix CVE-2024-22417?

Upgrade whoogle-search to 0.8.4 or later.

## Is CVE-2024-22417 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22417 exists.

## Other vulnerabilities in benbusby whoogle-search

- [CVE-2024-22203](https://insights.sbomify.com/CVE-2024-22203/): Whoogle Search Server Side Request Forgery vulnerability (critical 9.1)
- [CVE-2024-22205](https://insights.sbomify.com/CVE-2024-22205/): Whoogle Search Server Side Request Forgery vulnerability (critical 9.1)
- [CVE-2024-53305](https://insights.sbomify.com/CVE-2024-53305/): Whoogle allows attackers to execute arbitrary code via supplying a crafted search query (high 7.3)
- [CVE-2024-22204](https://insights.sbomify.com/CVE-2024-22204/): Whoogle Search Limited File Write vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22417 and fix it if it is affected.

What it is: CVE-2024-22417 is a medium-severity cross-site scripting vulnerability in benbusby whoogle-search, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22417 exists.

Affected packages and fixed versions:
- whoogle-search (PyPI): affected all versions; fixed in 0.8.4
- whoogle-search (PyPI): affected all versions; fixed in 0.8.4
- whoogle-search (PyPI): affected all versions; fixed in 0.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22417/ (Markdown: https://insights.sbomify.com/CVE-2024-22417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22417
- OSV: https://osv.dev/vulnerability/CVE-2024-22417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22417/
Summaries are generated and may contain mistakes; the official description above is the record.
