# CVE-2024-22419: concat built-in can corrupt memory in vyper

> The Vyper compiler's concat built-in can corrupt memory, potentially altering smart contract semantics or enabling code execution.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2024
- **Updated:** 2 Jun 2025
- **Also known as:** GHSA-2q8v-3gqq-4f8p, PYSEC-2024-103

## What is CVE-2024-22419?

CVE-2024-22419 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 18 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine. The `concat` built-in can write over the bounds of the memory buffer that was allocated for it and thus overwrite existing valid data. The root cause is that the `build_IR` for `concat` doesn't properly adhere to the API of copy functions (for `>=0.3.2` the `copy_bytes` function). A contract search was performed and no vulnerable contracts were found in production. The buffer overflow can result in the change of semantics of the contract. The overflow is length-dependent and thus it might go unnoticed during contract testing. However, certainly not all usages of concat will result in overwritten valid data as we require it to be in an internal function and close to the return statement where other memory allocations don't occur. This issue has been addressed in 0.4.0.

Weakness: CWE-787 (Out-of-bounds Write), CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2024-22419?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.4.0b1 |
| `vyper` | PyPI | From 0.3.0 | 0.4.0 |
| `vyper` | PyPI | From 0.3.0 | 0.4.0 |

Products: Vyperlang Vyper.

## How do I fix CVE-2024-22419?

Upgrade vyper to a fixed version for your release line: 0.4.0b1 or 0.4.0.

## Is CVE-2024-22419 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22419 exists.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22419 and fix it if it is affected.

What it is: CVE-2024-22419 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 18 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22419 exists.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.4.0b1
- vyper (PyPI): affected from 0.3.0; fixed in 0.4.0
- vyper (PyPI): affected from 0.3.0; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22419/ (Markdown: https://insights.sbomify.com/CVE-2024-22419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22419
- OSV: https://osv.dev/vulnerability/CVE-2024-22419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22419/
Summaries are generated and may contain mistakes; the official description above is the record.
