# CVE-2024-22421: Potential authentication and CSRF tokens leak in JupyterLab

> Attackers can steal authentication and CSRF tokens from JupyterLab users via malicious links, potentially leading to account takeover.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** BIT-jupyter-base-notebook-2024-22421, BIT-jupyter-notebook-2024-22421, BIT-jupyterlab-2024-22421, DEBIAN-CVE-2024-22421, GHSA-44cc-43rp-5947, PYSEC-2026-1706, PYSEC-2026-2534

## What is CVE-2024-22421?

CVE-2024-22421 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture. Users of JupyterLab who click on a malicious link may get their `Authorization` and `XSRFToken` tokens exposed to a third party when running an older `jupyter-server` version. JupyterLab versions 4.1.0b2, 4.0.11, and 3.6.7 are patched. No workaround has been identified, however users should ensure to upgrade `jupyter-server` to version 2.7.2 or newer which includes a redirect vulnerability fix.

Weakness: CWE-23 (Relative Path Traversal), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-22421?

11 open source packages ship an affected version, including jupyterlab, jupyter-base-notebook and jupyter-notebook. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab` | Bitnami | All versions | 3.6.7, 4.0.11 |
| `jupyterlab` | PyPI | All versions | 3.6.7, 4.0.11 |
| `jupyterlab` | PyPI | All versions | 3.6.7 |
| `jupyterlab` | PyPI | All versions | 3.6.7 |
| `jupyterlab` | PyPI | From 4.0.0 | 4.0.11 |
| `jupyterlab` | PyPI | From 4.0.0 | 4.0.11 |
| `jupyter-base-notebook` | Bitnami | From 7.0.0 | 7.0.7 |
| `jupyter-notebook` | Bitnami | From 7.0.0 | 7.0.7 |
| `notebook` | PyPI | From 7.0.0 | 7.0.7 |
| `notebook` | PyPI | From 7.0.0 | 7.0.7 |
| `notebook` | PyPI | From 7.0.0 | 7.0.7 |

Products: Fedoraproject Fedora, Jupyter Jupyterlab, Jupyter Notebook.

## How do I fix CVE-2024-22421?

Upgrade jupyterlab to a fixed version for your release line: 3.6.7 or 4.0.11.

## Is CVE-2024-22421 being exploited?

There is no known exploitation of CVE-2024-22421 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22421 and fix it if it is affected.

What it is: CVE-2024-22421 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-22421 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterlab (Bitnami): affected all versions; fixed in 3.6.7, 4.0.11
- jupyterlab (PyPI): affected all versions; fixed in 3.6.7, 4.0.11
- jupyterlab (PyPI): affected all versions; fixed in 3.6.7
- jupyterlab (PyPI): affected all versions; fixed in 3.6.7
- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.0.11
- jupyterlab (PyPI): affected from 4.0.0; fixed in 4.0.11
- jupyter-base-notebook (Bitnami): affected from 7.0.0; fixed in 7.0.7
- jupyter-notebook (Bitnami): affected from 7.0.0; fixed in 7.0.7
- notebook (PyPI): affected from 7.0.0; fixed in 7.0.7
- notebook (PyPI): affected from 7.0.0; fixed in 7.0.7
- notebook (PyPI): affected from 7.0.0; fixed in 7.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22421/ (Markdown: https://insights.sbomify.com/CVE-2024-22421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22421
- OSV: https://osv.dev/vulnerability/CVE-2024-22421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22421/
Summaries are generated and may contain mistakes; the official description above is the record.
