CVE-2024-2247 JFrog Artifactory Cross-Site Scripting

High 8.8 Published Updated

Attackers can execute arbitrary scripts in user browsers via DOM-based XSS in JFrog Artifactory, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-2247?

CVE-2024-2247 is a high-severity cross-site scripting vulnerability in Jfrog Artifactory, published on 13 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

JFrog Artifactory versions below 7.77.7, 7.82.1, are vulnerable to DOM-based cross-site scripting due to improper handling of the import override mechanism.

Weakness: CWE-79

Which versions are affected by CVE-2024-2247?

1 open source package ship an affected version, including artifactory. It affects 1 product.

PackageAffectedFixed in
artifactory BitnamiAll versions7.77.7, 7.82.1

Products include Jfrog Artifactory.

How do I fix CVE-2024-2247?

Upgrade artifactory to a fixed version for your release line: 7.77.7 or 7.82.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-2247 being exploited?

There is no known exploitation of CVE-2024-2247 in the wild and no public exploit code.

All Jfrog Artifactory vulnerabilities

Sources

Also known as BIT-artifactory-2024-2247, GHSA-gqg8-h7gm-47hq.

Is CVE-2024-2247 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free