CVE-2024-22513 Improper Privilege Management in djangorestframework-simplejwt
Attackers can access resources using disabled accounts due to missing validation in djangorestframework-simplejwt, bypassing authentication controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-22513?
CVE-2024-22513 is a medium-severity authentication bypass vulnerability in n/a, published on 16 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.
Weakness: CWE-306
Which versions are affected by CVE-2024-22513?
3 open source packages ship an affected version, including djangorestframework-simplejwt.
| Package | Affected | Fixed in |
|---|---|---|
djangorestframework-simplejwt PyPI | All versions | 5.5.1 |
djangorestframework-simplejwt PyPI | All versions | 5.5.1 |
djangorestframework-simplejwt PyPI | All versions | 5.5.1 |
Linux distribution packages (1)
python-djangorestframework-simplejwt openSUSE:Tumbleweed | All versions | 5.5.1-1.1 |
How do I fix CVE-2024-22513?
Upgrade djangorestframework-simplejwt to 5.5.1 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2024-22513 being exploited?
There is no known exploitation of CVE-2024-22513 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Sources
Also known as DEBIAN-CVE-2024-22513, GHSA-5vcc-86wm-547q, PYSEC-2026-1305, UBUNTU-CVE-2024-22513, openSUSE-SU-2025:15699-1.