{"answers":{"affected":"3 open source packages ship an affected version, including djangorestframework-simplejwt.","exploited":"There is no known exploitation of CVE-2024-22513 in the wild and no public exploit code.","fix":"Upgrade djangorestframework-simplejwt to 5.5.1 or later.","what":"CVE-2024-22513 is a medium-severity authentication bypass vulnerability in n/a, published on 16 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-22513 and fix it if it is affected.\n\nWhat it is: CVE-2024-22513 is a medium-severity authentication bypass vulnerability in n/a, published on 16 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-22513 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- djangorestframework-simplejwt (PyPI): affected all versions; fixed in 5.5.1\n- djangorestframework-simplejwt (PyPI): affected all versions; fixed in 5.5.1\n- djangorestframework-simplejwt (PyPI): affected all versions; fixed in 5.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-22513/ (Markdown: https://insights.sbomify.com/CVE-2024-22513/index.md)","id":"CVE-2024-22513","markdown":"https://insights.sbomify.com/CVE-2024-22513/index.md","name":"CVE-2024-22513","record":{"aliases":["DEBIAN-CVE-2024-22513","GHSA-5vcc-86wm-547q","PYSEC-2026-1305","UBUNTU-CVE-2024-22513","openSUSE-SU-2025:15699-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Django JWT library","requires_auth":"low_privilege","summary":"Attackers can access resources using disabled accounts due to missing validation in djangorestframework-simplejwt, bypassing authentication controls.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":1,"first_seen":"2024-04-15","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-04-15","kind":"exploitdb","ref":"51992","stars":null,"title":"djangorestframework-simplejwt 5.3.1 - Information Disclosure"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Improper Privilege Management in djangorestframework-simplejwt","id":"CVE-2024-22513","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":4,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2024-22514"},"packages":[{"ecosystem":"PyPI","fixed":["5.5.1"],"introduced":["0"],"last_affected":[],"package":"djangorestframework-simplejwt","purl":null,"source":"GHSA-5vcc-86wm-547q"},{"ecosystem":"PyPI","fixed":["5.5.1"],"introduced":["0"],"last_affected":[],"package":"djangorestframework-simplejwt","purl":"pkg:pypi/djangorestframework-simplejwt","source":"GHSA-5vcc-86wm-547q"},{"ecosystem":"PyPI","fixed":["5.5.1"],"introduced":["0"],"last_affected":[],"package":"djangorestframework-simplejwt","purl":"pkg:pypi/djangorestframework-simplejwt","source":"PYSEC-2026-1305"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.5.1-1.1"],"introduced":["0"],"last_affected":[],"package":"python-djangorestframework-simplejwt","purl":"pkg:rpm/opensuse/python-djangorestframework-simplejwt\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15699-1"}],"prev":{"headline":"Cross-site Scripting in JFinal","id":"CVE-2024-22497"},"products":["n/a"],"published":"2024-03-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-01","vendors":["n/a"]},"summary":"Attackers can access resources using disabled accounts due to missing validation in djangorestframework-simplejwt, bypassing authentication controls.","url":"https://insights.sbomify.com/CVE-2024-22513/"}