# CVE-2024-22513: Improper Privilege Management in djangorestframework-simplejwt

> Attackers can access resources using disabled accounts due to missing validation in djangorestframework-simplejwt, bypassing authentication controls.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2024
- **Updated:** 1 Nov 2024
- **Also known as:** DEBIAN-CVE-2024-22513, GHSA-5vcc-86wm-547q, PYSEC-2026-1305, UBUNTU-CVE-2024-22513, openSUSE-SU-2025:15699-1

## What is CVE-2024-22513?

CVE-2024-22513 is a medium-severity authentication bypass vulnerability in n/a, published on 16 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2024-22513?

3 open source packages ship an affected version, including djangorestframework-simplejwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djangorestframework-simplejwt` | PyPI | All versions | 5.5.1 |
| `djangorestframework-simplejwt` | PyPI | All versions | 5.5.1 |
| `djangorestframework-simplejwt` | PyPI | All versions | 5.5.1 |
| `python-djangorestframework-simplejwt` | openSUSE:Tumbleweed | All versions | 5.5.1-1.1 |

## How do I fix CVE-2024-22513?

Upgrade djangorestframework-simplejwt to 5.5.1 or later.

## Is CVE-2024-22513 being exploited?

There is no known exploitation of CVE-2024-22513 in the wild and no public exploit code.

Public exploit code:

- djangorestframework-simplejwt 5.3.1 - Information Disclosure (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22513 and fix it if it is affected.

What it is: CVE-2024-22513 is a medium-severity authentication bypass vulnerability in n/a, published on 16 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-22513 in the wild and no public exploit code.

Affected packages and fixed versions:
- djangorestframework-simplejwt (PyPI): affected all versions; fixed in 5.5.1
- djangorestframework-simplejwt (PyPI): affected all versions; fixed in 5.5.1
- djangorestframework-simplejwt (PyPI): affected all versions; fixed in 5.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22513/ (Markdown: https://insights.sbomify.com/CVE-2024-22513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22513
- OSV: https://osv.dev/vulnerability/CVE-2024-22513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22513/
Summaries are generated and may contain mistakes; the official description above is the record.
