# CVE-2024-22588: Kwik does not discard unused encryption keys

> Kwik library fails to discard unused encryption keys, potentially allowing attackers to recover sensitive data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-w8cp-frxc-55pj

## What is CVE-2024-22588?

CVE-2024-22588 is a medium-severity vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kwik commit 745fd4e2 does not discard unused encryption keys.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-22588?

2 open source packages ship an affected version, including tech.kwik:kwik.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tech.kwik:kwik` | Maven | All versions | 0.8 |
| `tech.kwik:kwik` | Maven | All versions | 0.8 |

## How do I fix CVE-2024-22588?

Upgrade tech.kwik:kwik to 0.8 or later.

## Is CVE-2024-22588 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22588 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-22588 and fix it if it is affected.

What it is: CVE-2024-22588 is a medium-severity vulnerability in n/a, published on 24 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-22588 exists.

Affected packages and fixed versions:
- tech.kwik:kwik (Maven): affected all versions; fixed in 0.8
- tech.kwik:kwik (Maven): affected all versions; fixed in 0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-22588/ (Markdown: https://insights.sbomify.com/CVE-2024-22588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-22588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-22588
- OSV: https://osv.dev/vulnerability/CVE-2024-22588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-22588/
Summaries are generated and may contain mistakes; the official description above is the record.
