CVE-2024-23114 Apache Camel: Camel-CassandraQL: Unsafe Deserialization from CassandraAggregationRepository

Critical 9.8 Published Updated

Attackers can execute arbitrary code via unsafe deserialization in the Apache Camel CassandraQL component's aggregation repository.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-23114?

CVE-2024-23114 is a critical unsafe deserialization vulnerability in Apache Camel, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.

Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Weakness: CWE-502

Which versions are affected by CVE-2024-23114?

8 open source packages ship an affected version, including org.apache.camel:camel-cassandraql. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-cassandraql MavenFrom 3.0.03.21.4
org.apache.camel:camel-cassandraql MavenFrom 3.0.03.21.4
org.apache.camel:camel-cassandraql MavenFrom 3.22.03.22.1
org.apache.camel:camel-cassandraql MavenFrom 3.22.03.22.1
org.apache.camel:camel-cassandraql MavenFrom 4.0.04.0.4
org.apache.camel:camel-cassandraql MavenFrom 4.0.04.0.4
2 more packages
org.apache.camel:camel-cassandraql MavenFrom 4.1.04.4.0
org.apache.camel:camel-cassandraql MavenFrom 4.1.04.4.0

Products include Apache Camel.

How do I fix CVE-2024-23114?

Upgrade org.apache.camel:camel-cassandraql to a fixed version for your release line: 3.21.4, 3.22.1, 4.0.4 or 4.4.0.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2024-23114 being exploited?

There is no known exploitation of CVE-2024-23114 in the wild and no public exploit code.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-m43p-55rf-8c2j.

Is CVE-2024-23114 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free