{"answers":{"affected":"1 open source package ship an affected version, including mediawiki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23178 exists.","fix":"Upgrade mediawiki to 1.41.1 or later.","what":"CVE-2024-23178 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 12 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-23178 and fix it if it is affected.\n\nWhat it is: CVE-2024-23178 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 12 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23178 exists.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.41.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23178/ (Markdown: https://insights.sbomify.com/CVE-2024-23178/index.md)","id":"CVE-2024-23178","markdown":"https://insights.sbomify.com/CVE-2024-23178/index.md","name":"CVE-2024-23178","record":{"aliases":["BIT-mediawiki-2024-23178","GHSA-wwvh-g99g-xv29"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki Phonos extension","requires_auth":"low_privilege","summary":"Cross-site scripting in MediaWiki Phonos extension allows attackers to execute arbitrary scripts via i18n messages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in the Phonos extension in MediaWiki before 1.40.2. PhonosButton.js allows i18n-based XSS via the phonos-purge-needed-error message.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2024-23178","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mediawiki:mediawiki","products":["mediawiki:mediawiki"],"type":"xss","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-23179"},"packages":[{"ecosystem":"Bitnami","fixed":["1.41.1"],"introduced":["0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2024-23178"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-23177"},"products":["n/a"],"published":"2024-01-12","related":[{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2023-37303","kev_date_added":null,"published":"2023-06-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-29904","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-29906","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2022-28205","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28206","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28209","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2021-36126","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["n/a"]},"summary":"Cross-site scripting in MediaWiki Phonos extension allows attackers to execute arbitrary scripts via i18n messages.","url":"https://insights.sbomify.com/CVE-2024-23178/"}