{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.rocketmq:rocketmq-all. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23321 in the wild and no public exploit code.","fix":"Upgrade org.apache.rocketmq:rocketmq-all to 5.3.0 or later.","what":"CVE-2024-23321 is a high-severity vulnerability in Apache RocketMQ, published on 22 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23321 and fix it if it is affected.\n\nWhat it is: CVE-2024-23321 is a high-severity vulnerability in Apache RocketMQ, published on 22 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-23321 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.rocketmq:rocketmq-all (Maven): affected from 4.5.2; fixed in 5.3.0\n- org.apache.rocketmq:rocketmq-all (Maven): affected from 4.5.2; fixed in 5.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23321/ (Markdown: https://insights.sbomify.com/CVE-2024-23321/index.md)","id":"CVE-2024-23321","markdown":"https://insights.sbomify.com/CVE-2024-23321/index.md","name":"CVE-2024-23321","record":{"aliases":["GHSA-q9w2-h4cw-8ghp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Message queue server","requires_auth":"low_privilege","summary":"An attacker with regular user privileges can expose administrator credentials, leading to full control of the Apache RocketMQ server.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"rocketmq","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions.\n\nAn attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list.\n\nTo mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache RocketMQ: Unauthorized Exposure of Sensitive Data","id":"CVE-2024-23321","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Envoy crashes when idle and request per try timeout occur within the backoff interval","id":"CVE-2024-23322"},"packages":[{"ecosystem":"Maven","fixed":["5.3.0"],"introduced":["4.5.2"],"last_affected":[],"package":"org.apache.rocketmq:rocketmq-all","purl":null,"source":"GHSA-q9w2-h4cw-8ghp"},{"ecosystem":"Maven","fixed":["5.3.0"],"introduced":["4.5.2"],"last_affected":[],"package":"org.apache.rocketmq:rocketmq-all","purl":"pkg:maven/org.apache.rocketmq/rocketmq-all","source":"GHSA-q9w2-h4cw-8ghp"}],"prev":{"headline":"Apache DolphinScheduler: Arbitrary js execution as root for authenticated users","id":"CVE-2024-23320"},"products":["Apache RocketMQ"],"published":"2024-07-22","related":[{"cvss_score":9.8,"headline":"Apache RocketMQ Command Execution","id":"CVE-2023-33246","kev_date_added":"2023-09-06","published":"2023-05-24"},{"cvss_score":9.8,"headline":"Apache RocketMQ: Possible remote code execution when using the update configuration function","id":"CVE-2023-37582","kev_date_added":null,"published":"2023-07-12"},{"cvss_score":5.3,"headline":"Directory traversal in Apache RocketMQ","id":"CVE-2019-17572","kev_date_added":null,"published":"2020-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"An attacker with regular user privileges can expose administrator credentials, leading to full control of the Apache RocketMQ server.","url":"https://insights.sbomify.com/CVE-2024-23321/"}