# CVE-2024-23321: Apache RocketMQ: Unauthorized Exposure of Sensitive Data

> An attacker with regular user privileges can expose administrator credentials, leading to full control of the Apache RocketMQ server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-q9w2-h4cw-8ghp

## What is CVE-2024-23321?

CVE-2024-23321 is a high-severity vulnerability in Apache RocketMQ, published on 22 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions.

An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list.

To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-23321?

2 open source packages ship an affected version, including org.apache.rocketmq:rocketmq-all. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.rocketmq:rocketmq-all` | Maven | From 4.5.2 | 5.3.0 |
| `org.apache.rocketmq:rocketmq-all` | Maven | From 4.5.2 | 5.3.0 |

Products: Apache Rocketmq.

## How do I fix CVE-2024-23321?

Upgrade org.apache.rocketmq:rocketmq-all to 5.3.0 or later.

## Is CVE-2024-23321 being exploited?

There is no known exploitation of CVE-2024-23321 in the wild and no public exploit code.

## Other vulnerabilities in Apache RocketMQ

- [CVE-2023-33246](https://insights.sbomify.com/CVE-2023-33246/): Apache RocketMQ Command Execution (critical 9.8, exploited in the wild)
- [CVE-2023-37582](https://insights.sbomify.com/CVE-2023-37582/): Apache RocketMQ: Possible remote code execution when using the update configuration function (critical 9.8)
- [CVE-2019-17572](https://insights.sbomify.com/CVE-2019-17572/): Directory traversal in Apache RocketMQ (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23321 and fix it if it is affected.

What it is: CVE-2024-23321 is a high-severity vulnerability in Apache RocketMQ, published on 22 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23321 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.rocketmq:rocketmq-all (Maven): affected from 4.5.2; fixed in 5.3.0
- org.apache.rocketmq:rocketmq-all (Maven): affected from 4.5.2; fixed in 5.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23321/ (Markdown: https://insights.sbomify.com/CVE-2024-23321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23321
- OSV: https://osv.dev/vulnerability/CVE-2024-23321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23321/
Summaries are generated and may contain mistakes; the official description above is the record.
