# CVE-2024-23329: changedetection.io API endpoint is not secured with API token

> Unauthenticated users can access watch history via API if UUID is known, exposing minimal privacy data in changedetection.io.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2024
- **Updated:** 13 Nov 2024
- **Also known as:** GHSA-hcvp-2cc7-jrwr, PYSEC-2024-15

## What is CVE-2024-23329?

CVE-2024-23329 is a low-severity missing authorization vulnerability in dgtlmoon changedetection.io, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

changedetection.io is an open source tool designed to monitor websites for content changes. In affected versions the API endpoint `/api/v1/watch/<uuid>/history` can be accessed by any unauthorized user. As a result any unauthorized user can check one's watch history. However, because unauthorized party first needs to know a watch UUID, and the watch history endpoint itself returns only paths to the snapshot on the server, an impact on users' data privacy is minimal. This issue has been addressed in version 0.45.13. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-23329?

3 open source packages ship an affected version, including changedetection.io and changedetection-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | From 0.39.14 | 0.45.13 |
| `changedetection-io` | PyPI | From 0.39.14 | 0.45.13 |
| `changedetection-io` | PyPI | From 0.39.14 | 0.45.13 |

Products: Webtechnologies Changedetection.

## How do I fix CVE-2024-23329?

Upgrade changedetection.io to 0.45.13 or later.

## Is CVE-2024-23329 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23329 exists.

## Other vulnerabilities in dgtlmoon changedetection.io

- [CVE-2026-35490](https://insights.sbomify.com/CVE-2026-35490/): changedetection.io has an Authentication Bypass via Decorator Ordering (critical 9.8)
- [CVE-2026-29039](https://insights.sbomify.com/CVE-2026-29039/): changedetection.io: XPath - Arbitrary File Read via unparsed-text() (high 8.8)
- [CVE-2026-29065](https://insights.sbomify.com/CVE-2026-29065/): changedetection.io: Zip Slip vulnerability in the backup restore functionality (high 8.8)
- [CVE-2026-27696](https://insights.sbomify.com/CVE-2026-27696/): changedetection.io Vulnerable to Server-Side Request Forgery (SSRF) via Watch URLs (high 8.6)
- [CVE-2026-33981](https://insights.sbomify.com/CVE-2026-33981/): Changedetection.io Discloses Environment Variables via jq env Builtin in Include Filters (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23329 and fix it if it is affected.

What it is: CVE-2024-23329 is a low-severity missing authorization vulnerability in dgtlmoon changedetection.io, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23329 exists.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected from 0.39.14; fixed in 0.45.13
- changedetection-io (PyPI): affected from 0.39.14; fixed in 0.45.13
- changedetection-io (PyPI): affected from 0.39.14; fixed in 0.45.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23329/ (Markdown: https://insights.sbomify.com/CVE-2024-23329/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23329
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23329
- OSV: https://osv.dev/vulnerability/CVE-2024-23329

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23329/
Summaries are generated and may contain mistakes; the official description above is the record.
