{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23333 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-23333 is a high-severity code injection vulnerability in LDAPAccountManager lam, published on 18 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23333 and fix it if it is affected.\n\nWhat it is: CVE-2024-23333 is a high-severity code injection vulnerability in LDAPAccountManager lam, published on 18 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-23333 in the wild and no public exploit code.\n\nAffected product: LDAPAccountManager lam. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23333/ (Markdown: https://insights.sbomify.com/CVE-2024-23333/index.md)","id":"CVE-2024-23333","markdown":"https://insights.sbomify.com/CVE-2024-23333/index.md","name":"CVE-2024-23333","record":{"aliases":["DEBIAN-CVE-2024-23333","GHSA-fm9w-7m7v-wxqv","UBUNTU-CVE-2024-23333"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"LDAP Account Manager","requires_auth":"high_privilege","summary":"Authenticated attackers with master password access can inject PHP code into log files for remote code execution if web server write permissions are misconfigured.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ldap_account_manager","vendor":"ldap-account-manager"}],"cvss":{"score":7.9,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"LDAP Account Manager (LAM) is a webfrontend for managing entries stored in an LDAP directory. LAM's log configuration allows to specify arbitrary paths for log files. Prior to version 8.7, an attacker could exploit this by creating a PHP file and cause LAM to log some PHP code to this file. When the file is then accessed via web the code would be executed. The issue is mitigated by the following: An attacker needs to know LAM's master configuration password to be able to change the main settings; and the webserver needs write access to a directory that is accessible via web. LAM itself does not provide any such directories. The issue has been fixed in 8.7. As a workaround, limit access to LAM configuration pages to authorized users.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LAM vulnerable to Authenticated Remote Code Execution","id":"CVE-2024-23333","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"aiohttp.web.static(follow_symlinks=True) is vulnerable to directory traversal","id":"CVE-2024-23334"},"packages":[],"prev":{"headline":"Client configured with permissive trust policies susceptible to rollback attack in Notary Project","id":"CVE-2024-23332"},"products":["lam"],"published":"2024-03-18","related":[{"cvss_score":8.8,"headline":"LAM has Authenticated Local File Inclusion (LFI) in PDF export","id":"CVE-2026-27894","kev_date_added":null,"published":"2026-03-17"},{"cvss_score":4.3,"headline":"LAM has incorrect regular expression in PDF export component that allows user to upload files of any type","id":"CVE-2026-27895","kev_date_added":null,"published":"2026-03-17"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2013-4453","kev_date_added":null,"published":"2013-11-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-21","vendors":["LDAPAccountManager"]},"summary":"Authenticated attackers with master password access can inject PHP code into log files for remote code execution if web server write permissions are misconfigured.","url":"https://insights.sbomify.com/CVE-2024-23333/"}