# CVE-2024-23341: TuiTse-TsuSin html injection vulnerability in `tuitse_html` function

> Attackers can inject malicious HTML via unquoted input in the tuitse_html function, potentially leading to script execution or data modification.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2024
- **Updated:** 11 Sep 2024
- **Also known as:** GHSA-m4m5-j36m-8x72, PYSEC-2024-22

## What is CVE-2024-23341?

CVE-2024-23341 is a medium-severity cross-site scripting vulnerability in i3thuan5 TuiTse-TsuSin, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TuiTse-TsuSin is a package for organizing the comparative corpus of Taiwanese Chinese characters and Roman characters, and extracting sentences of the Taiwanese Chinese characters and the Roman characters. Prior to version 1.3.2, when using `tuitse_html` without quoting the input, there is a html injection vulnerability. Version 1.3.2 contains a patch for the issue. As a workaround, sanitize Taigi input with HTML quotation.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-23341?

3 open source packages ship an affected version, including tuitse-tsusin and TuiTse-TsuSin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tuitse-tsusin` | PyPI | All versions | 1.3.2 |
| `tuitse-tsusin` | PyPI | All versions | 1.3.2 |
| `TuiTse-TsuSin` | PyPI | All versions | 1.3.2 |

Products: Ithuan Tuitse-Tsusin.

## How do I fix CVE-2024-23341?

Upgrade tuitse-tsusin to 1.3.2 or later.

## Is CVE-2024-23341 being exploited?

There is no known exploitation of CVE-2024-23341 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23341 and fix it if it is affected.

What it is: CVE-2024-23341 is a medium-severity cross-site scripting vulnerability in i3thuan5 TuiTse-TsuSin, published on 23 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23341 in the wild and no public exploit code.

Affected packages and fixed versions:
- tuitse-tsusin (PyPI): affected all versions; fixed in 1.3.2
- tuitse-tsusin (PyPI): affected all versions; fixed in 1.3.2
- TuiTse-TsuSin (PyPI): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23341/ (Markdown: https://insights.sbomify.com/CVE-2024-23341/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23341
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23341
- OSV: https://osv.dev/vulnerability/CVE-2024-23341

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23341/
Summaries are generated and may contain mistakes; the official description above is the record.
