# CVE-2024-23345: Nautobot has XSS potential in rendered Markdown fields

> Attackers can inject malicious scripts into Markdown fields, potentially executing code or hijacking user sessions in Nautobot.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2024
- **Updated:** 30 May 2025
- **Also known as:** GHSA-v4xv-795h-rv4h, PYSEC-2024-16

## What is CVE-2024-23345?

CVE-2024-23345 is a high-severity cross-site scripting vulnerability in nautobot, published on 22 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Nautobot is a Network Source of Truth and Network Automation Platform built as a web application.  All users of Nautobot versions earlier than 1.6.10 or 2.1.2 are potentially impacted by a cross-site scripting vulnerability. Due to inadequate input sanitization, any user-editable fields that support Markdown rendering, including are potentially susceptible to cross-site scripting (XSS) attacks via maliciously crafted data. This issue is fixed in Nautobot versions 1.6.10 and 2.1.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-23345?

5 open source packages ship an affected version, including nautobot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nautobot` | PyPI | All versions | 1.6.10 |
| `nautobot` | PyPI | All versions | 1.6.10 |
| `nautobot` | PyPI | From 2.0.0 | 2.1.2, 1.6.10 |
| `nautobot` | PyPI | From 2.0.0 | 2.1.2 |
| `nautobot` | PyPI | From 2.0.0 | 2.1.2 |

Products: Networktocode Nautobot.

## How do I fix CVE-2024-23345?

Upgrade nautobot to a fixed version for your release line: 1.6.10 or 2.1.2.

## Is CVE-2024-23345 being exploited?

There is no known exploitation of CVE-2024-23345 in the wild and no public exploit code.

## Other vulnerabilities in nautobot

- [CVE-2026-44797](https://insights.sbomify.com/CVE-2026-44797/): Nautobot: Webhook definitions could be used for server-side request forgery (SSRF) (high 8.5)
- [CVE-2024-34707](https://insights.sbomify.com/CVE-2024-34707/): Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages (high 7.5)
- [CVE-2024-32979](https://insights.sbomify.com/CVE-2024-32979/): Reflected Cross-site Scripting potential in all object list views in Nautobot (high 7.5)
- [CVE-2023-25657](https://insights.sbomify.com/CVE-2023-25657/): Remote code execution in Jinja2 template rendering in Nautobot (high 7.5)
- [CVE-2026-44798](https://insights.sbomify.com/CVE-2026-44798/): Nautobot: GitRepository.current_head field should not be writable through REST API (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23345 and fix it if it is affected.

What it is: CVE-2024-23345 is a high-severity cross-site scripting vulnerability in nautobot, published on 22 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23345 in the wild and no public exploit code.

Affected packages and fixed versions:
- nautobot (PyPI): affected all versions; fixed in 1.6.10
- nautobot (PyPI): affected all versions; fixed in 1.6.10
- nautobot (PyPI): affected from 2.0.0; fixed in 2.1.2, 1.6.10
- nautobot (PyPI): affected from 2.0.0; fixed in 2.1.2
- nautobot (PyPI): affected from 2.0.0; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23345/ (Markdown: https://insights.sbomify.com/CVE-2024-23345/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23345
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23345
- OSV: https://osv.dev/vulnerability/CVE-2024-23345

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23345/
Summaries are generated and may contain mistakes; the official description above is the record.
