# CVE-2024-23445: Elasticsearch Remote Cluster Search Cross Cluster API Key insufficient restrictions

> Attackers can bypass search restrictions in Elasticsearch cross-cluster API keys, accessing unauthorized documents and terms.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2024
- **Updated:** 31 Oct 2024
- **Also known as:** BIT-elasticsearch-2024-23445, UBUNTU-CVE-2024-23445

## What is CVE-2024-23445?

CVE-2024-23445 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 12 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

It was identified that if a  cross-cluster API key https://www.elastic.co/guide/en/elasticsearch/reference/8.14/security-api-create-cross-cluster-api-key.html#security-api-create-cross-cluster-api-key-request-body  restricts search for a given index using the query or the field_security parameter, and the same cross-cluster API key also grants replication for the same index, the search restrictions are not enforced during cross cluster search operations and search results may include documents and terms that should not be returned.

This issue only affects the  API key based security model for remote clusters https://www.elastic.co/guide/en/elasticsearch/reference/8.14/remote-clusters.html#remote-clusters-security-models  that was previously a beta feature and is released as GA with 8.14.0

Weakness: CWE-922 (Insecure Storage of Sensitive Information)

## Which versions are affected by CVE-2024-23445?

1 open source package ship an affected version, including elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elasticsearch` | Bitnami | From 8.10.0 | 8.14.0 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2024-23445?

Upgrade elasticsearch to 8.14.0 or later.

## Is CVE-2024-23445 being exploited?

There is no known exploitation of CVE-2024-23445 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23445 and fix it if it is affected.

What it is: CVE-2024-23445 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 12 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23445 in the wild and no public exploit code.

Affected packages and fixed versions:
- elasticsearch (Bitnami): affected from 8.10.0; fixed in 8.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23445/ (Markdown: https://insights.sbomify.com/CVE-2024-23445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23445
- OSV: https://osv.dev/vulnerability/CVE-2024-23445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23445/
Summaries are generated and may contain mistakes; the official description above is the record.
