# CVE-2024-23448: APM Server Insertion of Sensitive Information into Log File

> Attackers with log access can read sensitive data leaked into APM Server logs when Elasticsearch indexing fails.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-8r33-q5j5-rh7g, GO-2024-2556

## What is CVE-2024-23448?

CVE-2024-23448 is a medium-severity vulnerability in Elastic APM Server, published on 7 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered whereby APM Server could log at ERROR level, a response from Elasticsearch indicating that indexing the document failed and that response would contain parts of the original document. Depending on the nature of the document that the APM Server attempted to ingest, this could lead to the insertion of sensitive or private information in the APM Server logs.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-23448?

3 open source packages ship an affected version, including github.com/elastic/apm-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/elastic/apm-server` | Go | All versions | None |
| `github.com/elastic/apm-server` | Go | All versions | 8.12.1 |
| `github.com/elastic/apm-server` | Go | All versions | 8.12.1 |

Products: Elastic Apm Server.

## How do I fix CVE-2024-23448?

Upgrade github.com/elastic/apm-server to 8.12.1 or later.

## Is CVE-2024-23448 being exploited?

There is no known exploitation of CVE-2024-23448 in the wild and no public exploit code.

## Other vulnerabilities in Elastic APM Server

- [CVE-2023-31421](https://insights.sbomify.com/CVE-2023-31421/): Beats, Elastic Agent, APM Server, and Fleet Server Improper Certificate Validation issue (medium 5.9)
- [CVE-2024-37286](https://insights.sbomify.com/CVE-2024-37286/): APM Server Insertion of Sensitive Information into Log File (medium 5.7)
- [CVE-2026-78594](https://insights.sbomify.com/CVE-2026-78594/): Improper Handling of Highly Compressed Data in APM Server Leading to Persistent Denial of Service (medium 4.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23448 and fix it if it is affected.

What it is: CVE-2024-23448 is a medium-severity vulnerability in Elastic APM Server, published on 7 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23448 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/elastic/apm-server (Go): affected all versions; no fix listed
- github.com/elastic/apm-server (Go): affected all versions; fixed in 8.12.1
- github.com/elastic/apm-server (Go): affected all versions; fixed in 8.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23448/ (Markdown: https://insights.sbomify.com/CVE-2024-23448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23448
- OSV: https://osv.dev/vulnerability/CVE-2024-23448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23448/
Summaries are generated and may contain mistakes; the official description above is the record.
