CVE-2024-23449 Elasticsearch Uncaught Exception

Medium 4.3 Published Updated

Attackers can crash Elasticsearch ingest nodes by submitting encrypted PDFs to the attachment processor, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-23449?

CVE-2024-23449 is a medium-severity denial of service vulnerability in Elastic Elasticsearch, published on 29 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An uncaught exception in Elasticsearch >= 8.4.0 and < 8.11.1 occurs when an encrypted PDF is passed to an attachment processor through the REST API. The Elasticsearch ingest node that attempts to parse the PDF file will crash. This does not happen with password-protected PDF files or with unencrypted PDF files.

Weakness: CWE-248

Which versions are affected by CVE-2024-23449?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.

PackageAffectedFixed in
org.elasticsearch:elasticsearch MavenFrom 8.4.08.11.1
org.elasticsearch:elasticsearch MavenFrom 8.4.08.11.1
elasticsearch BitnamiFrom 8.4.08.11.1

Products include Elastic Elasticsearch.

How do I fix CVE-2024-23449?

Upgrade org.elasticsearch:elasticsearch to 8.11.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-23449 being exploited?

There is no known exploitation of CVE-2024-23449 in the wild and no public exploit code.

All Elastic Elasticsearch vulnerabilities

Sources

Also known as BIT-elasticsearch-2024-23449, GHSA-pw39-f3m5-cxfc, UBUNTU-CVE-2024-23449.

Is CVE-2024-23449 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free