# CVE-2024-23451: Elasticsearch Incorrect Authorization in the Remote Cluster Security API key based security model

> A malicious user with a valid API key can read arbitrary documents from any index on a remote cluster using the custom transport protocol.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-elasticsearch-2024-23451, GHSA-r3hx-qfh5-r9m7, UBUNTU-CVE-2024-23451

## What is CVE-2024-23451?

CVE-2024-23451 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 27 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Incorrect Authorization issue exists in the API key based security model for Remote Cluster Security, which is currently in Beta, in Elasticsearch 8.10.0 and before 8.13.0. This allows a malicious user with a valid API key for a remote cluster configured to use the new Remote Cluster Security to read arbitrary documents from any index on the remote cluster, and only if they use the Elasticsearch custom transport protocol to issue requests with the target index ID, the shard ID and the document ID. None of Elasticsearch REST API endpoints are affected by this issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-23451?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 8.10.0 | 8.13.0 |
| `org.elasticsearch:elasticsearch` | Maven | From 8.10.0 | 8.13.0 |
| `elasticsearch` | Bitnami | From 8.10.0 | 8.13.0 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2024-23451?

Upgrade org.elasticsearch:elasticsearch to 8.13.0 or later.

## Is CVE-2024-23451 being exploited?

There is no known exploitation of CVE-2024-23451 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23451 and fix it if it is affected.

What it is: CVE-2024-23451 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 27 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23451 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 8.10.0; fixed in 8.13.0
- org.elasticsearch:elasticsearch (Maven): affected from 8.10.0; fixed in 8.13.0
- elasticsearch (Bitnami): affected from 8.10.0; fixed in 8.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23451/ (Markdown: https://insights.sbomify.com/CVE-2024-23451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23451
- OSV: https://osv.dev/vulnerability/CVE-2024-23451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23451/
Summaries are generated and may contain mistakes; the official description above is the record.
