# CVE-2024-23454: Apache Hadoop: Temporary File Local Information Disclosure

> Local attackers can read sensitive data from temporary files created by Apache Hadoop due to missing permission settings.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2024
- **Updated:** 5 Sep 2025
- **Also known as:** CLEANSTART-2026-IQ19736, CLEANSTART-2026-XN74910, CLSA-2025-1752019359, CLSA-2025-1762474004, ECHO-9a21-ddab-7941, GHSA-f5fw-25gw-5m92, MINI-2m2m-m243-r8c9, MINI-3rwf-7wg4-g2gv, MINI-55pr-fvp5-gfhh, MINI-vm4c-fg8m-q9pw, OESA-2024-2347, OESA-2024-2348, OESA-2024-2349, OESA-2024-2350, OESA-2024-2351, OESA-2025-1038

## What is CVE-2024-23454?

CVE-2024-23454 is a medium-severity vulnerability in Apache Hadoop, published on 25 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache Hadoop’s RunJar.run() does not set permissions for temporary directory by default. If sensitive data will be present in this file, all the other local users may be able to view the content.
This is because, on unix-like systems, the system temporary directory is
shared between all local users. As such, files written in this directory,
without setting the correct posix permissions explicitly, may be viewable
by all other local users.

Weakness: CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2024-23454?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-common` | Maven | All versions | 3.4.0 |
| `org.apache.hadoop:hadoop-common` | Maven | All versions | 3.4.0 |

Products: Apache Hadoop.

## How do I fix CVE-2024-23454?

Upgrade org.apache.hadoop:hadoop-common to 3.4.0 or later.

## Is CVE-2024-23454 being exploited?

There is no known exploitation of CVE-2024-23454 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23454 and fix it if it is affected.

What it is: CVE-2024-23454 is a medium-severity vulnerability in Apache Hadoop, published on 25 Sep 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23454 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-common (Maven): affected all versions; fixed in 3.4.0
- org.apache.hadoop:hadoop-common (Maven): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23454/ (Markdown: https://insights.sbomify.com/CVE-2024-23454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23454
- OSV: https://osv.dev/vulnerability/CVE-2024-23454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23454/
Summaries are generated and may contain mistakes; the official description above is the record.
