# CVE-2024-23482: ZScalerService Local Privilege Escalation

> A local privilege escalation vulnerability in the Zscaler Client Connector allows attackers to gain elevated privileges on macOS systems.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vw2x-qjjw-279v

## What is CVE-2024-23482?

CVE-2024-23482 is a high-severity vulnerability in Zscaler Client Connector, published on 26 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The ZScaler service is susceptible to a local privilege escalation vulnerability found in the ZScalerService process. Fixed Version: Mac ZApp 4.2.0.241 and later.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-23482?

It affects 1 product.


Products: Zscaler Client Connector.

## How do I fix CVE-2024-23482?

No fix has been published for CVE-2024-23482 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-23482 being exploited?

There is no known exploitation of CVE-2024-23482 in the wild and no public exploit code.

## Other vulnerabilities in Zscaler Client Connector

- [CVE-2020-11633](https://insights.sbomify.com/CVE-2020-11633/): Memory corruption in n/a (critical 9.8)
- [CVE-2024-23463](https://insights.sbomify.com/CVE-2024-23463/): Anti-Tampering bypass via Repair App functionality (high 8.8)
- [CVE-2023-28804](https://insights.sbomify.com/CVE-2023-28804/): Linux ZCC allows unsigned updates, allowing elevated Code Execution (high 8.2)
- [CVE-2023-28799](https://insights.sbomify.com/CVE-2023-28799/): Open redirect in Client Connector (high 8.2)
- [CVE-2023-28800](https://insights.sbomify.com/CVE-2023-28800/): Output encoding missing in redrurl parameter (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23482 and fix it if it is affected.

What it is: CVE-2024-23482 is a high-severity vulnerability in Zscaler Client Connector, published on 26 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23482 in the wild and no public exploit code.

Affected product: Zscaler Client Connector. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23482/ (Markdown: https://insights.sbomify.com/CVE-2024-23482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23482
- OSV: https://osv.dev/vulnerability/CVE-2024-23482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23482/
Summaries are generated and may contain mistakes; the official description above is the record.
